This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 763149 - (GLUSTER-1417) issues with 'peer probe' and 'peer status'
issues with 'peer probe' and 'peer status'
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
All Linux
low Severity medium
: ---
: ---
Assigned To: Vijay Bellur
:
: 763272 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-23 02:50 EDT by Amar Tumballi
Modified: 2015-12-01 11:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Amar Tumballi 2010-08-23 02:50:35 EDT
On node4:

[root@node4 ~]# glusterd
[root@node4 ~]# gluster probe node3
unrecognized word: probe (position 0)
[root@node4 ~]# gluster peer probe node3
Probe failed
[root@node4 ~]# gluster peer probe node3
Probe on host node3 port 6969 already a friend
[root@node4 ~]# gluster peer status
Command Execution Failed
Command Execution failed
[root@node4 ~]# 

On node3

[root@node3 ~]# gluster peer probe node4
Probe successful
[root@node3 ~]# gluster peer probe node4
Probe on host node4 port 6969 already a friend
[root@node3 ~]# gluster peer status
Number of Peers: 1
hostname:node4, port:0, uuid:9b606654-e59c-4099-afb1-af931fa57e6d, state:4
[root@node3 ~]# 


Note that here I started glusterd on node3 after the 'peer probe' was issued on node4
Comment 1 Amar Tumballi 2010-09-01 05:19:47 EDT
Vijay/Shishir,

Does patch http://patches.gluster.com/patch/4336/ fix this issue? I couldn't see this coming recently.. just need to confirm and close this bug.
Comment 2 Amar Tumballi 2010-09-13 22:41:19 EDT
with latest git I have not seen this issue..
Comment 3 shishir gowda 2010-09-15 01:46:01 EDT
*** Bug 1540 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.