Bug 76318 - [via82cxxx_audio] 2.4.18-17.7.x kernel won't play sound
[via82cxxx_audio] 2.4.18-17.7.x kernel won't play sound
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-19 17:29 EDT by james scott
Modified: 2013-07-02 22:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-31 12:00:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james scott 2002-10-19 17:29:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-17.7.x i686)

Description of problem:
i upgraded my kernel from 2.4.18-10  to  2.4.18-17.7.x  from the Red Hat errata
page and now my sound won't work. my sound was working fine before the upgrade.
i ran the sndconfig tool and it gave me an error of : 

/lib/modules/2.4.18-17.7.x/kernel/drivers/sound/via82cxxx_audio.o: init_module:
No such device

/lib/modules/2.4.18-17.7.x/kernel/drivers/sound/via82cxxx_audio.o: inmod

/lib/modules/2.4.18-17.7.x/kernel/drivers/sound/via82cxxx_audio.o failed

/lib/modules/2.4.18-17.7.x/kernel/drivers/sound/via82cxxx_audio.o: inmod
sound-slot-0 failed

My sound card is : via technologies vt8233 ac97 audio controller

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. as root run sndconfig
2. as root run sndconfig
3. as root run sndconfig
	

Actual Results:  error message explain in description field.	

Expected Results:  sound card should have been configured and sound should be
working.

Additional info:

error

lib/modules/2.4.18-17.7.x/kernel/drivers/sound/via82cxxx_audio.o: init_module:
No such device

/lib/modules/2.4.18-17.7.x/kernel/drivers/sound/via82cxxx_audio.o: inmod

/lib/modules/2.4.18-17.7.x/kernel/drivers/sound/via82cxxx_audio.o failed

/lib/modules/2.4.18-17.7.x/kernel/drivers/sound/viacxxx_audio.o: inmod
sound-slot-0 failed
Comment 1 Arjan van de Ven 2002-10-20 05:17:12 EDT
Jeff... your ball
Comment 2 Jeff Garzik 2002-10-21 11:21:20 EDT

*** This bug has been marked as a duplicate of 54905 ***
Comment 3 Vehbi Sinan Tunalioglu 2002-12-19 05:36:29 EST
ftp://152.104.125.40/pc/ac97/alc650/linux.zip will help you. This is the ALSA 
Project. First you will "make install" end then you follow the instructions on 
the INSTALL file. You can also use the utilities under the utils directory to 
configure the ALSA. It is so easy.

My Config: 
MSI KT400
ATHLON XP
VIA 8233 south bridge

...
Comment 4 james scott 2002-12-25 21:12:15 EST
Dear   Sir's


When i try to download the zip file at this link that i received via e-mail from
your site i get this error message: " 550 /pc/ac97/alc650/linux.zip: No such
file or directory". this is the link that it happens at:
ftp://152.104.125.40/pc/ac97/alc650/linux.zip

This is in reference to " Bug 76318". Then when i click "O.K." for the error
message box it allows me to download. When i download it downloads a linux.zip
file but it won't let me unzip it. Even with root user. I'm using the link that
your e-mail provided. Am i doing something wrong? I there another site that i
can download this file from?  I need Help! Please:-) Thanks. 
                                                   james 
Comment 5 Vehbi Sinan Tunalioglu 2002-12-26 05:54:09 EST
In attention to James Scott,

Sir,
You are right. I receive the same messages. This is the Alsa project, and if 
you want todownload the driver, you can easily go to http://www.alsa-
project.org/ , so that you can get as much as information as you wish, also. 
The download page is http://www.alsa-project.org/download.php3 . I'm sure this 
URLs will help you...

Recommendation: Use the alsa utilities to configure your sound driver. This 
will help you much.

Thanks...
Comment 6 Vehbi Sinan Tunalioglu 2002-12-26 05:56:19 EST
A good explanation can be found on http://www.alsa-project.org/alsa-doc/doc-
php/template.php3?company=VIA&card=&chip=via8233a&module=via82xx ...
Comment 7 james scott 2002-12-26 14:35:09 EST

Dear Sir's 

Thank you for your help. I was able to download the Utils to configure the
driver but i'm confused on which driver to download for this kernal version? Can
any one  tell me which driver to download? Or will any 2002 driver do? I didn't
see any that refered to VIA ac97/alc650? Also does this kernel need a kernel
patch installed also? Red Hat Support told me that when they made this upgraded
kernel they didn't configure it for sound? Is this true or do i just need the
driver or both?  Any help would be greatly appreciated.

                                                   james
Comment 8 Jeff Garzik 2003-01-31 12:00:34 EST
Alan Cox wrote support for the new VT8233 audio chip found on Via-based
motherboards.  This support, added to the via82cxxx_audio driver, is what was
needed to resolve this bug.  It can be found in the current Red Hat beta
(phoebe) and also the latest Red Hat rawhide kernel.

Note You need to log in before you can comment on or make changes to this bug.