Bug 763229 - (GLUSTER-1497) gluster volume create creates incorrect volume file
gluster volume create creates incorrect volume file
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
All Linux
low Severity high
: ---
: ---
Assigned To: Pavan Vilas Sondur
:
: GLUSTER-1495 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-01 05:07 EDT by Anush Shetty
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2010-09-01 05:07:32 EDT
Here the subvolumes of both sep1-replicate-0 and sep1-replicate-1 are the same. 

Command used - gluster volume create sep1 replica 2 localhost:/tmp/export1 localhost:/tmp/export2 localhost:/tmp/export3 localhost:/tmp/export4

volume sep1-client-0
type protocol/client
option transport-type tcp
option remote-host localhost
option transport.socket.nodelay on
option remote-subvolume /tmp/export1
end-volume

volume sep1-client-1
type protocol/client
option transport-type tcp
option remote-host localhost
option transport.socket.nodelay on
option remote-subvolume /tmp/export2
end-volume

volume sep1-client-2
type protocol/client
option transport-type tcp
option remote-host localhost
option transport.socket.nodelay on
option remote-subvolume /tmp/export3
end-volume

volume sep1-client-3
type protocol/client
option transport-type tcp
option remote-host localhost
option transport.socket.nodelay on
option remote-subvolume /tmp/export4
end-volume

volume sep1-replicate-0
type cluster/replicate
#option read-subvolume on
#option favorite-child on
#option background-self-heal-count on
#option data-self-heal on
#option data-self-heal-algorithm on
#option data-self-heal-window-size on
#option metadata-self-heal on
#option entry-self-heal on
#option data-change-log on
#option metadata-change-log on
#option entry-change-log on
#option strict-readdir on
subvolumes sep1-client-0 sep1-client-1 
end-volume

volume sep1-replicate-1
type cluster/replicate
#option read-subvolume on
#option favorite-child on
#option background-self-heal-count on
#option data-self-heal on
#option data-self-heal-algorithm on
#option data-self-heal-window-size on
#option metadata-self-heal on
#option entry-self-heal on
#option data-change-log on
#option metadata-change-log on
#option entry-change-log on
#option strict-readdir on
subvolumes sep1-client-0 sep1-client-1 
end-volume

volume sep1-dht
type cluster/distribute
#option lookup-unhashed on
#option min-free-disk on
#option unhashed-sticky-bit on
subvolumes sep1-replicate-0 sep1-replicate-1 
end-volume

volume sep1-write-behind
type performance/write-behind
#option flush-behind on
#option cache-size on
#option disable-for-first-nbytes on
#option enable-O_SYNC on
#option enable-trickling-writes on
subvolumes sep1-dht
end-volume

volume sep1-read-ahead
type performance/read-ahead
#option force-atime-update on
#option page-count on
subvolumes sep1-write-behind
end-volume

volume sep1-io-cache
type performance/io-cache
#option priority on
#option cache-timeout on
#option cache-size on
#option min-file-size on
#option max-file-size on
subvolumes sep1-read-ahead
end-volume

volume sep1-quick-read
type performance/quick-read
#option priority on
#option cache-timeout on
#option cache-size on
#option max-file-size on
subvolumes sep1-io-cache
end-volume

volume sep1-stat-prefetch
type performance/stat-prefetch
subvolumes sep1-quick-read
end-volume
Comment 1 Vijay Bellur 2010-09-01 05:16:26 EDT
PATCH: http://patches.gluster.com/patch/4454 in master (mgmt/glusterd: Fix replicate/stripe subvolume count in volgen.)
Comment 2 shishir gowda 2010-09-01 23:16:40 EDT
*** Bug 1495 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.