Bug 76323 - kernel 2.4.18-17.7.x update causes reboot when loading NVidia drivers
kernel 2.4.18-17.7.x update causes reboot when loading NVidia drivers
Status: CLOSED DUPLICATE of bug 73733
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
athlon Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-19 20:04 EDT by baulv
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-19 22:35:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description baulv 2002-10-19 20:04:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010726
Netscape6/6.1

Description of problem:
After up2date'ing from  2.4.18-10 to  kernel 2.4.18-17.7.x and reinstalling
NVidia driver 3123 (and also 2960) the sytem locks up or reboots

Version-Release number of selected component (if applicable):
How reproducible:
Always

Steps to Reproduce:
1 .up2date from 2.4.18-10 to  kernel 2.4.18-17.7.x
2. reinstall NVidia drivers -GLX and -kernel (either 3123 or 2960)
3. enter runlevel 5
4. watch the reboot, or a locked machine with keyboard blinking LED's: Caps
Locks and Scroll Lock
	

Actual Results:  the system reboots 

Expected Results:  Entering a normal X startup with login screen

Additional info:

I never had any probelms installing NV drivers until now (OK one exception, the
hardcoded 64 meg mem limit).
After up2date'ing my kernel in rh7.3 from 2.4.18-10 (where 3123 was working
fine) to 2.4.18-17.7.x and then first trying to rpm -Uvh from rpm -rebuild
src.rpm's, (which used to work fine with 2.4.18-10) I first cannot install the
.src.rpm drivers NOR uninstall them.
I then download the .tar's and try to "make" them which "seems" to work, BUT
upon reboot I get serious lockup (with Caps Lock and Scroll Lock LED's blinking
on keyboard) and sometimes a spontaneous reboot when trying to boot kernel image
2.4.18-17.7.x.
If I boot with the "linux.bak" (2.4.18-10) it all works fine....
....until I try to reinstall the 3123 again. Then the "linux.bak" (2.4.18-10)
will not work, but at least the systems returns to runlevel 3 and does not crash.

Here's my attempt to "compile" the NV driver with various log-files at the
moment of crash:

[root@w1 NVIDIA_kernel-1.0-3123]# make >textfile
In file included from nv-linux.h:75, from nv.c:14:
/lib/modules/2.4.18-17.7.x/build/include/linux/highmem.h: In function `bh_kmap':
/lib/modules/2.4.18-17.7.x/build/include/linux/highmem.h:20: warning: pointer of
type `void *' used in arithmetic
In file included from nv-linux.h:75, from os-interface.c:25:
/lib/modules/2.4.18-17.7.x/build/include/linux/highmem.h: In function `bh_kmap':
/lib/modules/2.4.18-17.7.x/build/include/linux/highmem.h:20: warning: pointer of
type `void *' used in arithmetic
In file included from nv-linux.h:75, from os-registry.c:14:
/lib/modules/2.4.18-17.7.x/build/include/linux/highmem.h: In function `bh_kmap':
/lib/modules/2.4.18-17.7.x/build/include/linux/highmem.h:20: warning: pointer of
type `void *' used in arithmetic
[root@w1 NVIDIA_kernel-1.0-3123]#
(ouch!)
[root@w1 NVIDIA_kernel-1.0-3123]# cat textfile
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -1`\" > nv_compiler.h
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts
-Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__
-DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -DRM_HEAPMGR
-D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1
-DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=3123 -DNV_UNIX -DNV_LINUX -DNVCPU_X86 -I.
-I/lib/modules/2.4.18-17.7.x/build/include -Wno-cast-qual nv.c
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts
-Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__
-DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -DRM_HEAPMGR
-D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1
-DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=3123 -DNV_UNIX -DNV_LINUX -DNVCPU_X86 -I.
-I/lib/modules/2.4.18-17.7.x/build/include -Wno-cast-qual os-interface.c
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts
-Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__
-DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -DRM_HEAPMGR
-D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1
-DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=3123 -DNV_UNIX -DNV_LINUX -DNVCPU_X86 -I.
-I/lib/modules/2.4.18-17.7.x/build/include -Wno-cast-qual os-registry.c
ld -r -o Module-linux nv.o os-interface.o os-registry.o
ld -r -o NVdriver Module-linux Module-nvkernel
size NVdriver
text data bss dec hex filename
894487 55476 52396 1002359 f4b77 NVdriver
NVdriver installed successfully.

(yeah right)

(I then downloaded the 2960 drivers which gave me the same results.)

The /var/log/XFree86.0.log last lines are:
...
(II) Module fbdevhw: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.0.2
ABI class: XFree86 Video Driver, version 0.5
(II) LoadModule: "glx"
<end>

The /var/log/messages ends with :
...
Oct 18 18:10:45 w1 insmod: Warning: loading
/lib/modules/2.4.18-17.7.x/kernel/drivers/video/NVdriver will taint the kernel:
non-GPL license - NVIDIA
Oct 18 18:10:45 w1 insmod: See http://www.tux.org/lkml/#export-tainted for
information about tainted modules
Oct 18 18:10:45 w1 insmod: Module NVdriver loaded, with warnings
Oct 18 18:10:45 w1 kernel: nvidia: loading NVIDIA NVdriver Kernel Module
1.0-2960 Tue May 14 07:41:42 PDT 2002
Oct 18 18:12:18 w1 syslogd 1.4.1: restart.
...
GLX install reports no issues.
My system is an A7V333, 1800+, GF3-Ti200-128MB, nothing OC'd.
Comment 2 baulv 2002-10-19 22:35:20 EDT
[root@w1 i386]# rpm -q NVIDIA_kernel-1.0-3123.i386.rpm
package NVIDIA_kernel-1.0-3123.i386.rpm is not installed
[root@w1 i386]# rpm -ivh NVIDIA_GLX-1.0-3123.i386.rpm
Preparing...                ########################################### [100%]
package NVIDIA_GLX-1.0-3123 is already installed
[root@w1 i386]# rpm -ivh NVIDIA_GLX-1.0-3123.i386.rpm
Preparing...                ########################################### [100%]
package NVIDIA_GLX-1.0-3123 is already installed
[root@w1 i386]# rpm -q NVIDIA_kernel-1.0-3123.i386.rpm
package NVIDIA_kernel-1.0-3123.i386.rpm is not installed
[root@w1 i386]# rpm -q NVIDIA_kernel-1.0-3123.i386.rpm
package NVIDIA_kernel-1.0-3123.i386.rpm is not installed
[root@w1 i386]# rpm -e NVIDIA_GLX-1.0-3123.i386.rpm
error: package NVIDIA_GLX-1.0-3123.i386.rpm is not installed
[root@w1 i386]# rpm -ivh /usr/src/redhat/RPMS/i386/NVIDIA_kernel-1.0-3123.i386.rpm
Preparing...                ########################################### [100%]
package NVIDIA_kernel-1.0-3123 is already installed
[root@w1 i386]# rpm -ivh NVIDIA_GLX-1.0-3123.i386.rpm
Preparing...                ########################################### [100%]
package NVIDIA_GLX-1.0-3123 is already installed
[root@w1 i386]#
Comment 3 Mike A. Harris 2002-10-20 07:14:24 EDT

*** This bug has been marked as a duplicate of 73733 ***

Note You need to log in before you can comment on or make changes to this bug.