Bug 76326 - --prefix/--relocate not working in 8.0
Summary: --prefix/--relocate not working in 8.0
Status: CLOSED DUPLICATE of bug 75550
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-20 02:42 UTC by Jesse Keating
Modified: 2008-05-01 15:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-31 16:33:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample SPEC file. RPM build from this file on 7.2 handles --prefix fine, build on 8.0, not so fine. (20.61 KB, text/plain)
2002-10-20 02:49 UTC, Jesse Keating
no flags Details

Description Jesse Keating 2002-10-20 02:42:10 UTC
Description of problem:
Trying to use --prefix or --relocate when installing a relocatable package does
not work.  The package always uses the default prefix in the spec file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Create a spec file for an rpm that is relocatable
2.  rpm -ivh --prefix=/foo file.rpm
3.  observe the package igorning the --prefix option and defaulting to the
prefix in the spec file.
	

Actual Results:  The rpm seems to install to the prefix that is defined in the
.spec file, totally ignoring the command line argument.

Expected Results:  The rpm would install to the prefix issued.

Additional info:

I can take the same package and install it on a 7.2 system.  On the 7.2 system,
the --prefix argument is followed, and my package installs to  my prefix.  Not
so on 8.0

Comment 1 Jesse Keating 2002-10-20 02:49:08 UTC
Created attachment 81164 [details]
Sample SPEC file.  RPM build from this file on 7.2 handles --prefix fine, build on 8.0, not so fine.

Comment 2 Jason Merrill 2002-11-05 05:21:34 UTC

*** This bug has been marked as a duplicate of 75550 ***


Note You need to log in before you can comment on or make changes to this bug.