Bug 763277 - (GLUSTER-1545) transport type rdma fails in glusterd
transport type rdma fails in glusterd
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
All Linux
low Severity low
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-06 09:07 EDT by Anush Shetty
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2010-09-06 09:07:17 EDT
When I try mounting the client after volume start, the transport-type is getting defaulted to socket.

[2010-09-06 05:55:37.278508] D [xlator.c:960:xlator_mem_acct_init] fuse: Allocated mem_acct_rec for 81 types
[2010-09-06 05:55:37.373857] D [rpc-clnt.c:909:rpc_clnt_connection_init] glusterfs: defaulting frame-timeout to 30mins
[2010-09-06 05:55:37.373948] W [rpc-transport.c:841:rpc_transport_load] rpc-transport: missing 'option transport-type'. defaulting to "socket"
[2010-09-06 05:55:37.373969] D [rpc-transport.c:893:rpc_transport_load] rpc-transport: attempt to load file /opt/anush/gitrdma/lib/glusterfs/3.1.0git/rpc-transport/socket.so
[2010-09-06 05:55:37.375192] D [rpc-transport.c:219:__volume_option_value_validate] glusterfs: no range check required for 'option remote-port 6969'
[2010-09-06 05:55:37.375220] D [dict.c:326:dict_get] dict: @this=(nil) @key=0x2aaaaad68b34
[2010-09-06 05:55:37.375235] D [dict.c:326:dict_get] dict: @this=(nil) @key=0x2aaaaad68ba6
[2010-09-06 05:55:37.378154] D [rpc-clnt.c:1239:rpcclnt_cbk_program_register] rpc-clnt: New program registered: GlusterFS Callback, Num: 52743234, Ver: 1
Comment 1 Amar Tumballi 2010-09-06 11:06:35 EDT
Noticed that this is happening due to the rpc_clnt_init(); in glusterfsd-mgmt.c, which is used to talk to glusterd server on the same machine from 'glusterfsd', or to get the volume files from client 'glusterfs'. This connection is always over socket. Hence the log is harmless.

Will send patch to suppress this log.
Comment 2 Vijay Bellur 2010-09-06 11:08:20 EDT
Reducing severity as this is not a blocker.
Comment 3 Vijay Bellur 2010-09-06 11:23:40 EDT
PATCH: http://patches.gluster.com/patch/4608 in master (glusterfsd-mgmt.c: suppress a confusing log during rpc_clnt_init())

Note You need to log in before you can comment on or make changes to this bug.