Bug 763294 - (GLUSTER-1562) insufficient consistency check on start of glusterd
insufficient consistency check on start of glusterd
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
All Linux
low Severity low
: ---
: ---
Assigned To: shishir gowda
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-07 11:02 EDT by Csaba Henk
Modified: 2013-12-08 20:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Csaba Henk 2010-09-07 11:02:54 EDT
If the gluster instance has terminated its course in a dirty way -- eg. we do
a

  # pgrep gluster | xargs kill -9

(IRL assume a system crash, an OOM situation or a segfault), then when glusterd is started next time, it still shows the gluster volumes "started" -- albeit the gluserfs servers are not running.

Any inconstency in permanently stored state should be detected at startup time, so that if things gets cluttered, then, in lack of a better idea, as a last resort we can go for a full restart of the gluster ecosystem.

In this case, a check of pid files against volume info file seems to be sufficient.
Comment 1 Vijay Bellur 2010-09-22 07:44:07 EDT
PATCH: http://patches.gluster.com/patch/4927 in master (Restart all bricks which are down when glusterd comes up)

Note You need to log in before you can comment on or make changes to this bug.