Bug 7633 - Installer Crash while reading packages
Summary: Installer Crash while reading packages
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-06 18:01 UTC by Hugues Latour
Modified: 2015-01-07 23:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 17:53:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hugues Latour 1999-12-06 18:01:35 UTC
the trace back has many stack calls.  The error reside in comps.py line 50
unsubscriptable object

name = h[rpm.RPMTAG_NAME]

Comment 1 Hugues Latour 1999-12-10 15:15:59 UTC
First of all I have to say that I was trying to install from hardrive.

I try to debug the problem from the traceback.  Being a newie with python
I had to poke around.  I discovered that object 358 in the hdlist was
unsubscriptable the reason is!!!
object 358 was ls-IR (which should not have been there in the first place)

I found that there was an uncommented line in hardrives.py in the readHeaders
 Method
        	    if (n[len(n) - 4:] == '.rpm'):
I tried it with no avail!!!

I added this other line thinking it would definately work
   if (n[0-4] === 'ls-IR'): continue
Strike 2!!!

well I rename both ls-IR and ls-IR.gz and move them up one dir

that seem to have cure the sore.... Not pretty but lucky.

Comment 2 Hugues Latour 2000-01-10 14:38:59 UTC
Clarification:

The problem reside in the following script:
\linux\i386\RedHat\instimage\usr\lib\python1.5\site-packages\harddrive.pyc

It try to use all of the file in:
\linux\i386\RedHat\RPMS

What happens is that the program thinks that all the files in that DIR are RPMS
but ls-dir and ls-dir.gz aren't.  Originally ih the harddrive.py script they
tried
to filter on the .rpm but it is commented out.

1. My quick and dirty solution is to leave only rpm files in \linux\i386
\RedHat\RPMS
  So I moved ls-IR and ls-IR.gz elsewhere.

2. Optimum solution would be to uncomment the if statement and recompiled the
source.
   I am not a python user so I did not venture here at all.

Comment 3 Jay Turner 2000-02-04 17:53:59 UTC
Closing out this bug as the problem is indeed that there are non-RPM files in
the /RPMS directory.  We have made the error handling better for the next
release, so you should not have problems like this again.


Note You need to log in before you can comment on or make changes to this bug.