Bug 763311 - (GLUSTER-1579) glusterd killed and restarted and adding new brick fails
glusterd killed and restarted and adding new brick fails
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.1-alpha
All Linux
low Severity medium
: ---
: ---
Assigned To: shishir gowda
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-09 03:15 EDT by Lakshmipathi G
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTP
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lakshmipathi G 2010-09-09 03:15:43 EDT
created a volume with 2 dht bricks.added 3rd brick using add-brick. now kill 
glusterd and start glusted now add 4th brick.no errors found with add-brick and volume info- but 4th brick has no glusterfs process.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
4thbrick#gluster peer probe 10.192.141.187
Probe successful

4thbrick#ps ax|grep glust
27856 ?        Ssl    1:09 /old_opt/3.0.4/sbin/glusterfsd -f /root/laks/cfg.vol /opt -l client.log -L NONE
30407 ?        Ssl    0:00 glusterd
30417 pts/0    R+     0:00 grep glust

~~~~~~~~~~~~~~~
10.192.141.187#gluster volume add-brick dht 10.198.110.16:/mnt/a1 
10.192.141.187#gluster volume info

Volume Name: dht
Type: Distribute
Status: Started
Number of Bricks: 4
Transport-type: tcp
Bricks:
Brick1: 10.192.134.144:/mnt/a1
Brick2: 10.192.141.187:/mnt/a1
Brick3: 10.214.231.112:/mnt/a1
Brick4: 10.198.110.16:/mnt/a1
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Comment 1 Lakshmipathi G 2010-09-09 06:26:58 EDT
unable to reproduce this issue 3.1.0qa20.
Comment 2 shishir gowda 2010-09-09 22:19:53 EDT
Please reopen is reproduced again

Note You need to log in before you can comment on or make changes to this bug.