Bug 76340 - can't change window manager for gnome
can't change window manager for gnome
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: control-center (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-20 07:47 EDT by darkeye
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-20 16:27:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description darkeye 2002-10-20 07:47:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
when running gnome-control-center, can't find the possibility to change window
managers for gnome.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start gnome-control-center
2. try to find a way change the window manager
3.
	

Actual Results:  can't find any settings dialog to change the window manager

Expected Results:  a dialog to change the window manager

Additional info:

there was a graphical possibility to change the window manager through
gnome-control-center in RedHat 7.x. why remove it?

I wanted to change to sawfish WM instead of the default, but can't find a way to
do wo. frustrating.
Comment 1 Havoc Pennington 2002-10-20 11:13:49 EDT
The concept "window manager" is no longer visible in the GUI.

To change you do the same thing you would do to change any other application 
in your session; start the new application, run gnome-session-save (or 
check the "save setup" button on logout).

Window manager is slightly tricky as you need to kill the existing WM first, 
for WMs that don't support "--replace" or "-replace" options. 
For say metacity and fvwm2 that do -replace, you could run "fvmw2 -replace"
then save session.

For WMs without this feature, you'll need to kill the current WM e.g. 
"killall metacity" or open gnome-session-properties and remove the old WM 
using that.

You can use the same procedure to change your panel, file manager, or 
whatever.
Comment 2 R.K.Aa. 2002-10-20 12:15:50 EDT
I tried to kill Metacity, but it respawns automatically. So when - after a kill
- i try to start sawfish, i only get error messages telling that i can only run
one window manager at the time. I finally gave up on Gnome and now run KDE instead.
Comment 3 Havoc Pennington 2002-10-20 12:37:48 EDT
If metacity respawns too quickly, you can use gnome-session-properties to 
remove it from the session, or to set it to the "do not respawn" mode.
Or you can edit ~/.gnome2/session by hand.
Comment 4 darkeye 2002-10-20 16:27:43 EDT
I don't really understand your answer. I want to change the WM under my X, but
you say that 'The concept "window manager" is no longer visible in the GUI.'.
Then you describe how to change it. I see a contradiction here. (I can't change
something nonexitent, can I? Thus the concept of WM does exist.)

Also, can you elaborate on the --replace option? What do I call with this
option? Sawfish? Is there more documentation on this feature?

And why is there no GUI or 'easy' configuration file option to change it? (I
looked into ~/.gnome2/session, and couldn't find out what to chnage in there.)
The GUI to change the WM was there in RedHat Linux 7.x, and this task was quite
easy. Why remove features? Why make the GUI configuration dumber?

Not to mention an other bug (reported already in bugzilla), that all the sawfish
options are there in gnome-control-panel, but they just don't work, since
sawfish is not running. In fact, _nothing_ indicates what WM is running.

Very very frustrating.
Comment 5 Havoc Pennington 2002-10-20 17:56:07 EDT
You can change it using technical tools that aren't visible to users 
who don't know what a WM is. Some WMs accept a --replace or -replace flag
causing them to replace the currently-running window manager; Sawfish does not
support this yet, metacity and fvwm2 do among others.

Removing the WM concept from the GUI is necessary, the concept is impossible 
to explain to most users. Anyone who knows how the desktop works should have
no problem switching; it's done exactly the same way you'd switch any 
other app in your session. If you want a GUI then gnome-session-properties does
show what's currently running and lets you remove items.

It takes exactly 5 seconds to switch WMs, you just have to know what you're
doing. Which is appropriate, as for most users switching WMs will mean that 
various things break or don't work as expected. There should not be a 
"break my GUI" button. It's not reasonable to save technical users a minute or 
two of figuring out what's going on and in exchange get 99% of users into 
"my GUI is broken!" situations.
Comment 6 Jim Stewart 2003-12-09 19:28:28 EST
Havoc,

[Note: I'm not the originator of this thread, just another frustrated
user.]

It isn't as straightforward as this.

I was able to get rid of metacity by going to Preferences->More
Preferences->Session->Current Session and removing the metacity entry.
 I can then kill metacity and run sawfish ("sawfish &" in a terminal).
 It will even show sawfish in the Current Session list then.

However, when I run gnome-save-session, logout, and relogin, sawfish
doesn't start.  No window manager starts.  I can start sawfish up
again manually, but it won't save it for me.

If I add sawfish to Startup Programs and relogin, I can see that
gnome-session is trying to start sawfish, however it just hangs at
that point.  I get the impression it's trying to run sawfish as a
foreground task and it's waiting for it to finish.  I dunno if that's
really the case, but that's what it seems to be doing.  I tried
entering "sawfish &" as the command in Startup Programs, but it didn't
help.

I don't think the original poster is out of line in requesting an
easier way to switch WMs either.  Even if someone is a power user
who's been using X for 10 years, that doesn't mean they're familiar
with the latest features of Gnome 2.0 and RedHat's configuration. 
I've been using Sawfish for years, Gnome for years, RedHat for years,
and I've spent over an hour trying to get this to work.  It isn't a
"5-second job" and I'm not a clueless user.  It's simply unintuitive.
 I'm sure I'll figure it out, but your attitude regarding this issue
isn't very helpful.

Jim

Note You need to log in before you can comment on or make changes to this bug.