Bug 76341 - xcdroast crashed when adding a directory in "configuration"
xcdroast crashed when adding a directory in "configuration"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xcdroast (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Jay Turner
:
: 79552 79557 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-20 08:10 EDT by LENHOF
Modified: 2015-01-07 19:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-22 07:26:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed xcdroast-0.98alpha9-df.patch (860 bytes, patch)
2002-10-22 07:26 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description LENHOF 2002-10-20 08:10:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
- Launch xcdroast
- Go in configuration
- Try to add my directory /disc2
- 
	

Actual Results:  When running with strace xcdroast

stat64("/disc2", {st_mode=S_IFDIR|0755, st_size=12288, ...}) = 0
stat64("/bin/df", {st_mode=S_IFREG|0755, st_size=28972, ...}) = 0
pipe([6, 7])                            = 0
vfork()                                 = 2658
close(7)                                = 0
fstat64(6, {st_mode=S_IFIFO|0600, st_size=0, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40028000
read(6, "Syst\303\250me de\nfichiers          1K"..., 4096) = 140
write(2, "\n** ", 4
** )                    = 4
write(2, "ERROR **: ", 10ERROR **: )              = 10
write(2, "df -k output syntax error\n", 26df -k output syntax error
) = 26
write(2, "\naborting...\n", 13
aborting...
)         = 13
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
getpid()                                = 2635
kill(2635, SIGABRT)                     = 0
--- SIGABRT (Aborted) ---
+++ killed by SIGABRT +++
[root@mylinux root]#

So it seems to be a bug with internationalisation of df.... indeed going with
LANG=C xcdroast does'nt show this problem

For information :

[root@mylinux root]# cat /etc/fstab
/dev/vol01/vol01_lvroot /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
/dev/vol01/lv_disc1     /disc1                  ext3    defaults        1 2
/dev/vol01/lv_disc2     /disc2                  ext3    defaults        1 2
/dev/vol01/vol01_lviso  /iso                    ext3    defaults        1 2
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/vol01/vol01_lvtmp  /tmp                    ext3    defaults        1 2
/dev/vol01/toto         /toto                   ext3    defaults        1 2
/dev/vol01/vol01_lvswap swap                    swap    defaults        0 0
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,kudzu,ro 0
0
/dev/cdrom1             /mnt/cdrom1             iso9660 noauto,owner,kudzu,ro 0
0
/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0
[root@mylinux root]#

[root@mylinux root]# cat /etc/sysconfig/i18n
LANG="fr_FR.UTF-8"
SUPPORTED="fr_FR.UTF-8:fr_FR:fr"
SYSFONT="latarcyrheb-sun16"
[root@mylinux root]#


Additional info:
Comment 1 Tim Waugh 2002-10-20 11:56:33 EDT
Fixed package is 0.98a9-19.
Comment 2 LENHOF 2002-10-20 17:12:39 EDT
In rawhide there's only version 18... Please push version 19 to rawhide

Thanks

Have fun,

JYL
Comment 3 LENHOF 2002-10-21 14:41:27 EDT
Sorry to insist,

I found the new release...

But this bug does'nt seem to go away...

xcdroast

** WARNING **: The X-CD-Roast wrapper seems not to have the correct
         permissions set

** WARNING **: So do as root something like that:
         chown root:cdwrite /usr/lib/xcdroast-0.98/bin/xcdrwrap;
         chmod 2755 /usr/lib/xcdroast-0.98/bin/xcdrwrap


** WARNING **: For more information read
        /usr/share/doc/xcdroast-0.98a9/README.nonroot

*** NOTE ***:
        ---------------------------------------------------------------
        This permission warning and the following set-uid bit warnings
        can be safely ignored, if you want to run X-CD-Roast as root only.
        ---------------------------------------------------------------

** ERROR **: df -k output syntax error

aborting...
Abandon
[root@mylinux root]# rpm -qf `which xcdroast`
xcdroast-0.98a9-19
[root@mylinux root]

and moreover.... now this does'nt work under LANG=C :

[root@mylinux root]# LANG=C xcdroast

** WARNING **: The X-CD-Roast wrapper seems not to have the correct
         permissions set

** WARNING **: So do as root something like that:
         chown root:cdwrite /usr/lib/xcdroast-0.98/bin/xcdrwrap;
         chmod 2755 /usr/lib/xcdroast-0.98/bin/xcdrwrap


** WARNING **: For more information read
        /usr/share/doc/xcdroast-0.98a9/README.nonroot

*** NOTE ***:
        ---------------------------------------------------------------
        This permission warning and the following set-uid bit warnings
        can be safely ignored, if you want to run X-CD-Roast as root only.
        ---------------------------------------------------------------

** ERROR **: df -k output syntax error

aborting...
Abandon
[root@mylinux root]#
Comment 4 LENHOF 2002-10-21 16:06:46 EDT
I've had a quick look on how you've done your patch...and how it works 

And found that

root@mylinux root]# /bin/sh -c 'LANG=C /bin/df -k' /disc2
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/vol01/lvroot      8063408   4402512   3251296  58% /
/dev/hda1               101089     18040     77830  19% /boot
/dev/vol01/lv_disc1    1224896    787108    387984  67% /disc1
/dev/vol01/lv_disc2   12096536  10534764    947372  92% /disc2
/dev/vol01/vol01_lviso
                       3031568   1936292    972072  67% /iso
none                    127696         0    127696   0% /dev/shm
/dev/vol01/vol01_lvtmp
                       1015960     17020    947332   2% /tmp
/dev/vol01/toto        4031680   2008708   1818172  53% /toto
[root@mylinux root]#

is different of

[root@mylinux root]# LANG=C /bin/df -k /disc2

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/vol01/lv_disc2   12096536  10534764    947372  92% /disc2
[root@mylinux root]#

Not found the solution yet....but approaching

Tips : Look at io.c 

Have fun,

JYL
Comment 5 LENHOF 2002-10-21 16:43:48 EDT
Perhaps a better way to fix the bug is to remove your patch and make one with
this type of modification of the io.c

strcpy(line,"LANG=C ");
        if (stat_file(DF)) {
                strcat(line,DF);
                strcat(line," \"");
                strcat(line,path);
                strcat(line,"\"");
        } else {
                strcat(line,DF2);
                strcat(line," \"");
                strcat(line,path);
                strcat(line,"\"");
        }
Comment 6 Tim Waugh 2002-10-22 07:26:04 EDT
Created attachment 81524 [details]
fixed xcdroast-0.98alpha9-df.patch
Comment 7 Tim Waugh 2002-10-23 10:16:20 EDT
Fixed package is xcdroast-0.98a9-20.
Comment 8 Tim Waugh 2002-12-13 06:13:13 EST
*** Bug 79557 has been marked as a duplicate of this bug. ***
Comment 9 Tim Waugh 2002-12-19 16:05:43 EST
*** Bug 79552 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.