Bug 76342 - mgetty logrotate config fills /var/log
mgetty logrotate config fills /var/log
Status: CLOSED DUPLICATE of bug 68096
Product: Red Hat Linux
Classification: Retired
Component: mgetty (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-20 09:17 EDT by Mika Ilmaranta
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mika Ilmaranta 2002-10-20 09:17:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020913

Description of problem:
mgetty 1.1.28-3 logrotate config is filling /var/log/ with
mgetty.log.ttyS?.x.x.x.x... files where x is any single digit number 0-9.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Everytime logrotate is run.
2.
3.
	

Additional info:

Maybe mgetty's log file naming convention should be changed from
mgetty.log.ttyS? to mgetty.ttyS?.log to allow the use of * in
/etc/logrotate.d/mgetty. It simply does not work with * as last component of
what to rotate. Other possible solution would be to change logrotate so it would
not touch anything that ends with number.

For now fixed with removing * from mgetty's logrotate config and giving exact
paths to log-files.
Comment 1 Miguel Armas 2002-11-07 05:33:09 EST
It can be fixed just changing /var/log/mgetty.log.tty*   
for /var/log/mgetty.log.ttyS? in /etc/logrotate.d/mgetty  
Comment 2 giulioo 2003-02-20 13:50:01 EST

*** This bug has been marked as a duplicate of 68096 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:49:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.