Bug 763420 - (GLUSTER-1688) openSUSE 11.3 failed to mount export from gluster-nfs server
openSUSE 11.3 failed to mount export from gluster-nfs server
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
nfs-alpha
All Linux
low Severity medium
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-23 19:18 EDT by Bernard Li
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTP
Mount Type: nfs
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernard Li 2010-09-23 19:18:58 EDT
When I tried to mount a gluster volume exported via gluster-nfs using the following command, it would hang and eventually timeout:

# mount gluster-nfs:/export /share

However, if I specify the nfsvers option, it works:

# mount -o nfsvers=3 gluster-nfs:/export /share

Perhaps there is some issue with NFS version detection?

Running nfs_beta_rc14 on the server, and nfs-client-1.2.1-7.2 on openSUSE 11.3 client.
Comment 1 Shehjar Tikoo 2010-09-23 23:46:32 EDT
What kernel version does distro have? Recent kernels have moved the default nfs mount versions to 4 instead of 3.
Comment 2 Bernard Li 2010-09-24 00:40:21 EDT
Kernel version is 2.6.34-12-desktop and you're right, it also times out if I execute the following:

# mount -o nfsvers=4 gluster-nfs:/export /share

I found this bugzilla entry for openSUSE 11.3 regarding NFS version fallback:

https://bugzilla.novell.com/show_bug.cgi?id=557138

Will do more troubleshooting and report back tomorrow.

Thanks.
Comment 3 Bernard Li 2010-09-24 14:03:22 EDT
I have updated my nfs-client to 1.2.1-34.2 (from openSUSE Factory) which supposedly has the above openSUSE bug 557138 fixed.  However, it still won't fall back from NFSv4 to NFSv3.

What does gluster-nfs return when a mount request fails?  ENOENT or EPERM or neither?

Please let me know if I can provide any additional information to fix this issue, thanks!
Comment 4 Shehjar Tikoo 2010-09-25 02:41:50 EDT
(In reply to comment #3)
> I have updated my nfs-client to 1.2.1-34.2 (from openSUSE Factory) which
> supposedly has the above openSUSE bug 557138 fixed.  However, it still won't
> fall back from NFSv4 to NFSv3.
> 
> What does gluster-nfs return when a mount request fails?  ENOENT or EPERM or
> neither?

I see the negotiation depends on receiving a ENOENT from the server but because we dont support nfsv4, we dont register a NFSv4 service with portmapper. After that, portmap does not return a NFSv4 port to nfsv4 clients trying to connect. So a timeout occurs.


> 
> Please let me know if I can provide any additional information to fix this
> issue, thanks!
Comment 5 Shehjar Tikoo 2010-10-05 04:43:48 EDT
Closing. There is nothing that can be done here because we dont register a NFSv4 program with the portmapper, so the question about returning a ENOENT or EPERM for a NFSv3 export doesnt arise.

I may consider registering a fake nfsv4 program just to return a ENOENT to be nfs client friendly but that will prevent a genuine nfs v4 server from registering on the same machine.

Note You need to log in before you can comment on or make changes to this bug.