Bug 763432 - (GLUSTER-1700) write fops are bailing out on a distribute setup
write fops are bailing out on a distribute setup
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: rdma (Show other bugs)
mainline
All Linux
low Severity high
: ---
: ---
Assigned To: Raghavendra G
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-24 09:20 EDT by Raghavendra G
Modified: 2015-12-01 11:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vijay Bellur 2010-09-24 07:10:31 EDT
PATCH: http://patches.gluster.com/patch/4962 in master (rpc/rpc-transport: fix frame-loss during rdma-reads.)
Comment 1 Raghavendra G 2010-09-24 09:20:34 EDT
test: dbench -s -t 18000 10
setup: 4 node distribute.

some write fops are not propagated to rpcsvc from rdma. The reason for this is the failure of rdma to identify when all the rdma reads are complete.

Note You need to log in before you can comment on or make changes to this bug.