Bug 763436 - (GLUSTER-1704) showmount works after some time interval.
showmount works after some time interval.
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.1-alpha
All Linux
low Severity low
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-25 02:31 EDT by Lakshmipathi G
Modified: 2015-12-01 11:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTP
Mount Type: nfs
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lakshmipathi G 2010-09-25 02:31:57 EDT
nfs started ,after some time(few seconds ) on brick where "volume start" command is issued.


10.192.134.144#gluster volume start beta
Starting volume beta has been successful
10.192.134.144#showmount -e localhost
showmount: RPC: Program not registered
10.192.134.144#showmount -e localhost
showmount: RPC: Program not registered
10.192.134.144#showmount -e localhost
showmount: RPC: Program not registered
10.192.134.144#showmount -e localhost
Export list for localhost:
/beta *
Comment 1 Shehjar Tikoo 2010-09-25 03:19:11 EDT
This is expected behaviour from 3.1beta. For a distributed config, NFS will now wait till all bricks have connected before making them visible to nfs clients. I agree there is some confusion here whether the gnfs init failed or whether the bricks have not connected yet. I'll see if this can be made more definite.
Comment 2 Shehjar Tikoo 2010-10-05 04:52:27 EDT
This behaviour will change now because distribute supports doing a fresh lookup by itself. Changing to 3.1.1. Only requires removing code and I want to do this carefully.
Comment 3 Shehjar Tikoo 2010-10-26 04:54:02 EDT
Not relevant anymore since nfs init does not block on all child-ups from dht.
Comment 4 Saurabh 2011-02-17 01:31:34 EST
Does this bug needs verfication from QA side?

If yes,

 Does the steps mentioned to introduce this bug are enough, else please provide test plan.
Comment 5 Shehjar Tikoo 2011-02-17 01:32:31 EST
(In reply to comment #4)
> Does this bug needs verfication from QA side?
> 
> If yes,
> 
>  Does the steps mentioned to introduce this bug are enough, else please provide
> test plan.

No. It does not neet verification.

Note You need to log in before you can comment on or make changes to this bug.