Bug 76347 - Unable to update packages - missing scrollkeeper
Unable to update packages - missing scrollkeeper
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-20 12:13 EDT by Rick Richardson
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-20 14:02:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Richardson 2002-10-20 12:13:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.18-17.7.x i686)

Description of problem:
I am unable to update the packages installed on my system.  Whever I try to
update I get a dialog box that says there was a dependency failure -
scrollkeeper is needed by ggv and evolution, and it can't find scrollkeeper.

It seems to me that redhat-config-packages should be able to resolve the
dependency and figure out what package it needs to install to get scrollkeeper. 
I went thru the list of packages displayed by redhat-config-packages and could
not locate it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade install of 8.0 over 7.2
2. Start-><something>->Packages
3. select ggv and evolution for installation
	

Actual Results:  Fails to update any packages.

Expected Results:  Should update packages.

Additional info:

Sheesh, the start menu items are confusing.  3 different categories to look in
for system settings, and I still have not figured out how to enable telnetd and
sshd.  But I digress!
Comment 1 Rick Richardson 2002-10-20 12:24:10 EDT
OK, so I went directly to the CD and tried to install scrollkeeper. with "rpm -i
scrollkeeper".  Bu rpm claims its already installed.  Yet redhat-config-packages
doesn't seem to be able to figure this out.
Comment 2 Rick Richardson 2002-10-20 12:28:08 EDT
Tried to do a "rpm -i --force scrollkeeper*rpm" from the CD.  It just hangs and
I have to use a kill -9 to kill rpm, plain kill does not work.
Comment 3 Rick Richardson 2002-10-20 14:02:22 EDT
What a mess the 8.0 upgrade is.  I removed /var/lib/rpm/__db* and rebuilt the
rpm database with rpmdb --rebuild (why isn't this a GUI option when
redhat-config-packages decides it can't do an install?).

Then, I was able to add the evolution packages.  Interestingly enough,
redhat-config-packages added far more than evolution.

So I got to wondering what would happen if I started redhat-config-packages
again, selected nothing new, and moved on to update.  In theory nothing should
happen, right?  Nope.  It installed even more stuff, a bunch of configuation
utilities and the "missing" openssh server (hopefully I'll get a Gnome menu item
to configure it, too).  I can't wait till this pass finishes and I try this a
third time.  What are the odds that it will pick up even more packages that it
forgot to install when I did the original 7.2 -> 8.0 upgrade?

Comment 4 Jeremy Katz 2002-10-31 17:53:00 EST
Upgrades don't pull in new packages.  redhat-config-packages's logic is such
that it makes it easy to get the package groups you want installed.

Note You need to log in before you can comment on or make changes to this bug.