Bug 763478 - (GLUSTER-1746) volume delete fails after volume stop
volume delete fails after volume stop
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.1-alpha
All Linux
low Severity high
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-30 02:10 EDT by Pranith Kumar K
Modified: 2010-09-30 05:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijay Bellur 2010-09-30 01:52:17 EDT
PATCH: http://patches.gluster.com/patch/5097 in master (mgmt/glusterd: remove debug messages in cleanup_and_exit)
Comment 1 Pranith Kumar K 2010-09-30 02:04:15 EDT
glusterfs volume stop resulted in a crash in cleanup_and_exit. the pid file is not cleaned up because of this. So the run directory under volume dir deletion resulted in an error. fixed the crash to fix the issue.
Comment 2 Pranith Kumar K 2010-09-30 02:10:16 EDT
volume delete fails because the volume files are not cleaned up in the volume directory.


[2010-09-30 11:31:20.653580] I [glusterd-store.c:419:glusterd_store_delete_volume] : Removed pranith-fuse.vol
[2010-09-30 11:31:20.653655] E [glusterd-store.c:436:glusterd_store_delete_volume] : Failed to rmdir: /etc/glusterd/vols/pranith, errno: 39
[2010-09-30 11:31:20.653696] D [glusterd-store.c:616:glusterd_store_handle_destroy] : Returning 0
[2010-09-30 11:31:20.653731] D [glusterd-store.c:443:glusterd_store_delete_volume] : Returning -1
[2010-09-30 11:31:20.653763] D [glusterd-op-sm.c:4312:glusterd_op_commit_perform] : Returning -1
[2010-09-30 11:31:20.653797] E [glusterd3_1-mops.c:1208:glusterd3_1_commit_op] : Commit failed

Note You need to log in before you can comment on or make changes to this bug.