Bug 76348 - modules.conf's scsi_hostadapter duplicated upon kernel update
Summary: modules.conf's scsi_hostadapter duplicated upon kernel update
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-20 16:13 UTC by Per Winkvist
Modified: 2014-03-17 02:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-21 04:42:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Per Winkvist 2002-10-20 16:13:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
I had scsi_hostadapter set to AM53C974 in modules.conf. When I updated to the new kernel in 'updates' it added a new 'alias scsi_hostadapter1 tmscsim'. When I reboot it first loads AM53.. and then tmscsim which makes the system ooops right after tmscsim has been loaded.

When probing for scsi adapter it always gives me tmscsim, but I wanna use AM53C974 instead since it works better for me. Once I removed the extra line and reran mkinitrd it worked fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Change scsi_hostadapter
2. Update kernel
3. Verify that you have a new scsi_hostadapter line
	

Additional info:

Comment 1 Bill Nottingham 2002-10-21 04:42:48 UTC
Can you reproduce the *exact* steps to get the new entry added to modules.conf?
Does running /usr/sbin/module_upgrade do it?

Comment 2 Per Winkvist 2002-10-21 18:49:17 UTC
I repeated the sequence I did yesterday and this time the new kernel booted fine. Very strange.   
  
Another thing I observed yesterday was that after I had used the rescue disc and removed the  
extra scsi_hostadapter line and rebooted it didn't actually work right away. So I had to use the  
rescue disk again. The second time I removed the initrd and did mkinitrd again, then rebooted  
successfully...  
  
A final thing, upon boot I get the following : 
---------------------------------------------------------------------------- 
SCSI subsystem driver Revision: 1.00 
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2 
PCI: Found IRQ 11 for device 00:09.0 
scsi0 : AM53/79C974 PCscsi driver rev. 0.5; host I/O address: 0xe400; irq: 11 
 
  Vendor: SEAGATE   Model: ST34520N          Rev: 1444 
  Type:   Direct-Access                      ANSI SCSI revision: 02 
Attached scsi disk sda at scsi0, channel 0, id 4, lun 0 
SCSI device sda: 8888924 512-byte hdwr sectors (4551 MB) 
 sda: sda1 sda2 sda3 sda4 < sda5 > 
.... 
---------------------------------------------------------------------------- 
 



Note You need to log in before you can comment on or make changes to this bug.