Bug 763534 - (GLUSTER-1802) Gluster volume creation failed
Gluster volume creation failed
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
nfs-beta
All Linux
low Severity high
: ---
: ---
Assigned To: Vijay Bellur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-04 15:24 EDT by Dhandapani
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vijay Bellur 2010-10-04 12:44:18 EDT
> +------------------------------------------------------------------------------+
> [2010-10-05 00:26:44.25780] I
> [glusterd-handler.c:633:glusterd_handle_cli_list_friends] glusterd: Received
> cli list req
> [2010-10-05 00:26:44.26192] W [glusterd3_1-mops.c:1454:glusterd_handle_rpc_msg]
> : Returning 0
> [2010-10-05 00:37:01.161975] I [glusterd-op-sm.c:4901:glusterd_op_set_cli_op] :
> Returning 0
> [2010-10-05 00:37:01.162191] I
> [glusterd-handler.c:745:glusterd_handle_create_volume] glusterd: Received
> create volume req
> [2010-10-05 00:37:01.163153] I
> [2010-10-05 00:37:01.163623] I
> [glusterd3_1-mops.c:1054:glusterd3_1_cluster_lock] glusterd: Sent lock req to 1
> peers
> [2010-10-05 00:37:01.163640] I
> [glusterd-op-sm.c:4439:glusterd_op_sm_transition_state] : Transitioning from 0
> to 1 due to event 1
> [2010-10-05 00:37:01.163653] W
> [glusterd3_1-mops.c:1454:glusterd_handle_rpc_msg] : Returning 0
> [2010-10-05 00:39:51.882231] I [glusterd-op-sm.c:4901:glusterd_op_set_cli_op] :
> Returning 16
> [2010-10-05 00:39:51.882283] E
> [glusterd3_1-mops.c:1318:glusterd_handle_rpc_msg] : Unable to set cli op: 16





Looks like one more volume create request was issued before the first one was completed and hence the failure. Can you please confirm?
Comment 1 Dhandapani 2010-10-04 15:24:48 EDT
Gluster volume creation command failed with error code: 16

Log trace: /etc/glusterd/logs/etc-glusterfs-glusterd.vol.log
 

Given volfile:
+------------------------------------------------------------------------------+
  1: volume management
  2:     type mgmt/glusterd
  3:     option working-directory /etc/glusterd
  4:     option transport-type socket,rdma
  5:     option transport.socket.listen-port 6969
  6:     option transport.rdma.listen-port 6968
  7:     # option listen-port 6969
  8: end-volume
  9: 

+------------------------------------------------------------------------------+
[2010-10-05 00:26:44.25780] I [glusterd-handler.c:633:glusterd_handle_cli_list_friends] glusterd: Received cli list req
[2010-10-05 00:26:44.26192] W [glusterd3_1-mops.c:1454:glusterd_handle_rpc_msg] : Returning 0
[2010-10-05 00:37:01.161975] I [glusterd-op-sm.c:4901:glusterd_op_set_cli_op] : Returning 0
[2010-10-05 00:37:01.162191] I [glusterd-handler.c:745:glusterd_handle_create_volume] glusterd: Received create volume req
[2010-10-05 00:37:01.163153] I [glusterd-utils.c:1985:glusterd_friend_find_by_hostname] glusterd: Friend server2 found.. state: 3
[2010-10-05 00:37:01.163327] I [glusterd-utils.c:222:glusterd_lock] glusterd: Cluster lock held by 7a1d9097-790e-426f-940c-6eafb2784f84
[2010-10-05 00:37:01.163343] I [glusterd-handler.c:2636:glusterd_op_txn_begin] glusterd: Acquired local lock
[2010-10-05 00:37:01.163356] I [glusterd-op-sm.c:4758:glusterd_op_sm_inject_event] glusterd: Enqueuing event: 1
[2010-10-05 00:37:01.163367] I [glusterd-handler.c:2640:glusterd_op_txn_begin] glusterd: Returning 0
[2010-10-05 00:37:01.163623] I [glusterd3_1-mops.c:1054:glusterd3_1_cluster_lock] glusterd: Sent lock req to 1 peers
[2010-10-05 00:37:01.163640] I [glusterd-op-sm.c:4439:glusterd_op_sm_transition_state] : Transitioning from 0 to 1 due to event 1
[2010-10-05 00:37:01.163653] W [glusterd3_1-mops.c:1454:glusterd_handle_rpc_msg] : Returning 0
[2010-10-05 00:39:51.882231] I [glusterd-op-sm.c:4901:glusterd_op_set_cli_op] : Returning 16
[2010-10-05 00:39:51.882283] E [glusterd3_1-mops.c:1318:glusterd_handle_rpc_msg] : Unable to set cli op: 16
[2010-10-05 00:39:51.883085] I [glusterd-op-sm.c:4241:glusterd_op_send_cli_response] : Returning 0
[2010-10-05 00:39:51.883107] W [glusterd3_1-mops.c:1454:glusterd_handle_rpc_msg] : Returning 0
[2010-10-05 00:45:04.928066] I [glusterd-handler.c:675:glusterd_handle_cli_get_volume] glusterd: Received get vol req
[2010-10-05 00:45:04.928172] W [glusterd3_1-mops.c:1454:glusterd_handle_rpc_msg] : Returning 0
Comment 2 Vijay Bellur 2010-10-08 04:28:49 EDT
PATCH: http://patches.gluster.com/patch/5355 in master (support for configuring keepalive idle time)
Comment 3 Vijay Bellur 2010-10-09 06:36:56 EDT
PATCH: http://patches.gluster.com/patch/5397 in master (set keepalive for client connections)

Note You need to log in before you can comment on or make changes to this bug.