Bug 76358 - xv does not work properly with my Trident CyberBlade a1i
xv does not work properly with my Trident CyberBlade a1i
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-20 16:19 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.3.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-25 14:46:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Faulty config file (3.20 KB, text/plain)
2002-10-23 18:53 EDT, Need Real Name
no flags Details
Faulty x server log file (29.69 KB, text/plain)
2002-10-23 18:54 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-10-20 16:19:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
xv does not show properly stuff (eg. mplayer).
A vertical slice of the screen is translated to the right.
I have a Trident CyberBlade a1i onboard my Acer 351TEV.
It didnt happen with RedHat 7.3.
Workaround:
I have successfully solved the problem downgrading from XFree86-4.2.0-72 to
XFree86-4.2.0-8.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open a divx with mplayer using the xv video output
	

Actual Results:  The video shows corrupted. (It didnt happen with RedHat 7.3)

Expected Results:  The video should have shown nicely.

Additional info:

The problem has been introduced with the new rpm XFree86-4.2.0-72 shipped with
RedHat 8.
Other RedHat version were not affected.
Comment 1 Mike A. Harris 2002-10-23 12:28:05 EDT
Unfortunately, there is nothing that I can do to debug this problem, as
I do not have any Trident video hardware, nor documentation.  All I
can do is leave this bug report open, and get you to try new versions
of the driver that become available from the upstream driver maintainer
whom I have CC'd.

If you would like to test the latest version, I have XFree86 CVS RPM
packages available on ftp://people.redhat.com/mharris/testing/live-grenades
however they are not production ready, but rather an experimental
developmental work in progress.

You can also try the "vesa" driver.

Note, you didn't need to downgrade.  You could have just took
the single trident_drv.o file from RHL 7.3 and used it with the supplied
X server in 8.0.

In any case, please attach your XF86Config and X server log file from
the problematic 8.0 X server (not the 7.3 one you've downgraded to.

Comment 2 Need Real Name 2002-10-23 18:53:04 EDT
Created attachment 81804 [details]
Faulty config file
Comment 3 Need Real Name 2002-10-23 18:54:01 EDT
Created attachment 81805 [details]
Faulty x server log file
Comment 4 Need Real Name 2002-10-23 18:58:35 EDT
I did some more tests:
- package 72 with old trident_drv.o from package 8 works FINE. No more bug.
- package 72 with new trident_drv.o from package 20021018 do not load at all
- vesa video output could not be tested on my machine
- x11 video output is always FINE
I have just posted my config and log files as requested.
Comment 5 Mike A. Harris 2002-10-25 22:47:57 EDT
It is not clear what you are saying above.  Please be much much more
detailed in the information you are providing.

>- package 72 with old trident_drv.o from package 8 works FINE. No more bug.

I presume from "package 72" that you mean XFree86 4.2.0-72.  Please state
things like this clearly and explicitly so there is no room for confusion.
If you're using the package from RHL 8, with the driver from RHL 8, and
not having a problem, then this isn't a bug.  If I'm misinterpreting
what you're saying however, please elaborate.

>- package 72 with new trident_drv.o from package 20021018 do not load at all

If you're refering to using XFree86 4.2.0-72 from RHL 8.0 with the
trident_drv.o from my XFree86 CVS RPM packages from 20021018, there
is no way that that is even remotely supposed to work.  Again, you're
being totally vague so I can only make random guesses.  Please explicitly
spell out packages in the form <name>-<version>-<release> to avoid
confusion.  Do not mix CVS code with older releases.  If you are using
anything from CVS, make sure you're using EVERYTHING from CVS.

Awaiting clarification and greater details.
Comment 6 Need Real Name 2002-10-26 05:10:04 EDT
Hello. Sorry for the inconvenience. I will try to be more clear. 

If I simply install RedHat 8 on my machine then xv DO NOT WORK properly. If I
install RedHat 7.3 instead xv works perfectly. 
I guess there is a bug introduced by RedHat 8.

Thanks to your help I noticed that the problem is carried in by the file
/usr/X11R6/lib/modules/drivers/trident_drv.o of rpm package XFree86 4.2.0-72.
The best workaround I have found is changing that file with the one from rpm
package XFree86 4.2.0-8 (the rpm provided by RedHat 7.3).

I am sorry but would like to avoid upgrading my system to a unstable XFree
distribution. I have just tried out CVS trident_drv.o unsuccessfully so I came
back to XFree86 4.2.0-8 trident_drv.o.

There must be a difference between trident_drv.o of package XFree86 4.2.0-8 and
trident_drv.o of package XFree86 4.2.0-72. 
That difference is the problem itself.

Comment 7 Mike A. Harris 2002-11-05 10:09:54 EST
Sorry you're having trouble.  There's nothing I can do about it really
other than relay your problem report to the Trident driver maintainer,
whom is carbon copied on this bug report.  The Trident driver included
in XFree86 4.2.0 in Red Hat Linux 7.3 is the one that is stock.  The
one included in Red Hat Linux 8.0 is one which includes many bugfixes
that Alan did and has solved many users problems.  It seems it has
created a problem for you and that is unfortunate.  Overall the new
driver is far superior for more users however, and that is why it is
present.

You also have the option of trying the latest XFree86 CVS snapshot release
available from ftp://people.redhat.com/mharris/testing/live-grenades/
which has Alan's latest Trident driver.

While running Red Hat Linux 8.0, and testing the latest XFree86 CVS
snapshot available from the above FTP directory, does this problem
go away?
Comment 8 Alex Lancaster 2002-12-15 08:58:52 EST
I can confirm that I had exactly the same problem with my Trident Cyber 9525/DVD
LCD monitor on a Fujitsu Lifebook S-4542, and this is due to the non-stock
Trident driver that ships with Red Hat 8.0.

XFree86-4.2.0-72 in Psyche/Red Hat 8.0 displayed the identical problem as
described by the report with the vertical split screen.  

The workaround that Mike Harris suggested solved the problem.  I grabbed the
XFree86-4.2.0-8 RPM that ships with Valhalla/Red Hat 7.3, then used the
following to extract the Trident driver file
/usr/X11R6/lib/modules/drivers/trident_drv.o:

$ rpm2cpio XFree86-4.2.0-8.i386.rpm > XFree86.cpio
$ cpio -ivd < XFree86.cpio

I moved the old RPM version aside, and copied the trident_drv.o file into place. 

This restored the DVD screen playback to it's former (correct, no screen
splitting) state which it had as of Red Hat 7.3.  I am not on broadband
connection so I have not had a chance to test Mike Harris' pretest XFree86 RPMs
for XFree86 4.2.1 (CVS snapshot version).  As soon as I get access to a fast
connection I will try the pretest RPMs to see if the problem remains in the
Trident driver that ships with that version.

Alex
Comment 9 Mike A. Harris 2002-12-17 16:04:27 EST
Problem has been reported upstream, so I am closing this now as WONTFIX
as I have neither the hardware, nor the documentation to investigate this.

It will either be fixed in XFree86 4.3.0 when released, or some future
release perhaps.  Please follow up bug reports directly to XFree86.org
for this hardware by sending email to xfree86@xfree86.org
Comment 10 Muiz Motani 2003-01-23 09:01:34 EST
I also had the same problem (and wasted much time trying to fix my
/etc/X11/XF86Config file). A good workaround to this problem is to get a new
driver published by the maintainer. You can find it at
http://www.xfree86.org/~alanh.
Comment 11 Need Real Name 2003-01-23 12:34:40 EST
The trident_drv.o actually proposed bu the mantainer does not fix the problem for me. I still use the one which came with Red Hat 7.3 (build#8). 
Comment 12 Need Real Name 2003-04-10 16:52:16 EDT
Problem have been solved on RH9.
Comment 13 Mike A. Harris 2003-06-25 14:46:55 EDT
Cool, thanks.  Closing bug as resolved in CURRENTRELEASE of Red Hat Linux 9.
(XFree86 4.3.0-2)

Note You need to log in before you can comment on or make changes to this bug.