Bug 763620 - (GLUSTER-1888) volfile generation error ignored
volfile generation error ignored
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
All Linux
low Severity medium
: ---
: ---
Assigned To: Pranith Kumar K
:
: GLUSTER-1924 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-09 19:02 EDT by Csaba Henk
Modified: 2011-03-28 02:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Csaba Henk 2010-10-09 19:02:19 EDT
Apply the following patch:

--------------
--- a/xlators/mgmt/glusterd/src/glusterd-volgen.c
+++ b/xlators/mgmt/glusterd/src/glusterd-volgen.c
@@ -1248,7 +1248,8 @@ glusterd_create_volfiles (glusterd_volinfo_t *volinfo)
         ret = glusterd_fetchspec_notify (THIS);

 out:
-        return ret;
+        gf_log ("", GF_LOG_ERROR, "I'm a loser baby");
+        return -1;
 }

 void

--------------

With this, you still get:

# gluster volume create pop 192.168.2.10:/tmp/ex0
Creation of volume pop has been successful

Glusterd just goes on happily.

2010-10-10 00:55:55.176990] E [glusterd-volgen.c:1251:glusterd_create_volfiles] : I'm a loser baby
[2010-10-10 00:55:55.198101] D [glusterd-utils.c:1194:glusterd_volume_compute_cksum] : Returning with 0
[2010-10-10 00:55:55.198254] D [glusterd-op-sm.c:4931:glusterd_op_commit_perform] : Returning 0
[2010-10-10 00:55:55.198281] I [glusterd3_1-mops.c:1330:glusterd3_1_commit_op] glusterd: Sent op req to 0 peers
[2010-10-10 00:55:55.198311] D [glusterd3_1-mops.c:1342:glusterd3_1_commit_op] glusterd: Returning 0
[2010-10-10 00:55:55.198327] I [glusterd-op-sm.c:5116:glusterd_op_sm_inject_event] glusterd: Enqueuing event: 'GD_OP_EVENT_ALL_ACC'

etc.
Comment 1 Vijay Bellur 2011-03-25 04:12:07 EDT
PATCH: http://patches.gluster.com/patch/6566 in master (mgmt/glusterd: fail create volume on create-volfiles failure)
Comment 2 Pranith Kumar K 2011-03-25 19:58:21 EDT
*** Bug 1924 has been marked as a duplicate of this bug. ***
Comment 3 Vijay Bellur 2011-03-27 22:17:37 EDT
PATCH: http://patches.gluster.com/patch/6601 in master (mgmt/glusterd: Add the new volume only after all ops succeed)

Note You need to log in before you can comment on or make changes to this bug.