Bug 763650 - (GLUSTER-1918) Default Init fails against qa46, should run when any one of the transport is available
Default Init fails against qa46, should run when any one of the transport is ...
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Vijay Bellur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-11 19:25 EDT by Harshavardhana
Modified: 2015-03-22 21:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTNR
Mount Type: ---
Documentation: DNR
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harshavardhana 2010-10-11 16:38:11 EDT
Closing related to DNS issue with wrong entries in /etc/hosts
Comment 1 Harshavardhana 2010-10-11 19:25:52 EDT
[root@platform logs]# less etc-glusterfs-glusterd.vol.log
[2010-10-11 16:13:08.678436] I [glusterd.c:274:init] management: Using /etc/glusterd as working directory
[2010-10-11 16:13:08.745281] C [rdma.c:3817:rdma_init] rpc-transport/rdma: No IB devices found
[2010-10-11 16:13:08.745312] E [rdma.c:4744:init] rdma.management: Failed to initialize IB Device
[2010-10-11 16:13:08.745329] E [rpc-transport.c:965:rpc_transport_load] rpc-transport: 'rdma' initialization failed
[2010-10-11 16:13:08.745394] I [glusterd.c:95:glusterd_uuid_init] glusterd: generated UUID: 1bc70cba-23a1-4565-9ef0-309360442b44
Given volfile:
+------------------------------------------------------------------------------+
  1: volume management
  2:     type mgmt/glusterd
  3:     option working-directory /etc/glusterd
  4:     option transport-type socket,rdma
  5:     option transport.socket.keepalive-time 10
  6:     option transport.socket.keepalive-interval 2
  7: end-volume
  8: 

+------------------------------------------------------------------------------+
[root@platform logs]# 


This would eventually hang gluster command line during volume create, since the rpc is not registered, but i still see the glusterd running @ 24007.

Note You need to log in before you can comment on or make changes to this bug.