Bug 763680 - (GLUSTER-1948) For each subvolume started, glusterfs process takes up around 30-35MB more memory
For each subvolume started, glusterfs process takes up around 30-35MB more me...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
All Linux
low Severity medium
: ---
: ---
Assigned To: Raghavendra G
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-14 07:44 EDT by Raghavendra G
Modified: 2015-12-01 11:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTNR
Mount Type: All
Documentation: DNR
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra G 2010-10-14 07:44:51 EDT
Nfs server allocates an inode table for each subvolume. Each inode table allocates a mempool of around 200,000 entries for inode and dentry. This contributes to relatively high memory used by each of subvolumes. One of the possible solutions would be to lower the number of entries in inode and dentry mem-pool.
Comment 1 Shehjar Tikoo 2010-10-19 04:18:43 EDT
just to be sure we fix the right bug, this should be seen for every glusterfs daemon because that mem allocation is coming from inode_table_new. There this value is hard-coded. Patch coming soon.
Comment 2 Anand Avati 2010-10-26 23:11:43 EDT
PATCH: http://patches.gluster.com/patch/5575 in master (core: Use lru_limit as count for inode and dentry mempool)

Note You need to log in before you can comment on or make changes to this bug.