Bug 763696 - (GLUSTER-1964) need a cmd to get process state dumps
need a cmd to get process state dumps
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
All All
low Severity low
: ---
: ---
Assigned To: Kaushal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-15 05:37 EDT by Amar Tumballi
Modified: 2015-12-01 11:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amar Tumballi 2010-10-15 05:37:23 EDT
We need a gluster command itself to collect state dump, instead of current way of issuing SIGUSR1 on a process id. This is more handy.
Comment 1 Amar Tumballi 2011-04-25 05:33:48 EDT
Please update the status of this bug as its been more than 6months since its filed (bug id < 2000)

Please resolve it with proper resolution if its not valid anymore. If its still valid and not critical, move it to 'enhancement' severity.
Comment 2 Amar Tumballi 2011-08-22 03:33:45 EDT
Please work on this.

Shishir had sent a patch to handle this: http://patches.gluster.com/patch/7039/ but this may not be enough.

What we should have from this feature.

* Enable an CLI option for setting 'statedump' path for given volume. (and the individual brick dump will have brick-path in its log file name, so it should be uniq per volume).

* Enable a CLI command to take the statedump on all the brick processes which are running at the moment (per volume).

* Enhance the above command of taking statedump to consider only few parts of state-dumps. (inode/memory/priv/stack etc).

Let me know if you have any questions on this.

Note You need to log in before you can comment on or make changes to this bug.