Bug 763697 - (GLUSTER-1965) need a cmd to get io-stat details
need a cmd to get io-stat details
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
All All
low Severity low
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-15 05:40 EDT by Amar Tumballi
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amar Tumballi 2010-10-15 05:40:00 EDT
we need a 'gluster' command to get the io-stats details, because we are using 'setfattr' with key 'glusterfs.io-stats-dump' to get the details, and also that, it doesn't control per brick, and can't be done over a NFS mount.

We need a way from gluster cli to control this.
Comment 1 Vijay Bellur 2011-03-10 08:09:33 EST
PATCH: http://patches.gluster.com/patch/6378 in master (rpc: Changes for handling unix domain sockets avoid race)
Comment 2 Vijay Bellur 2011-03-10 08:09:39 EST
PATCH: http://patches.gluster.com/patch/6379 in master (debug/io-stats: Changes for handling gluster profile)
Comment 3 Vijay Bellur 2011-03-10 08:09:45 EST
PATCH: http://patches.gluster.com/patch/6380 in master (rpc/xdr: Add gluster profile and brick op structures)
Comment 4 Vijay Bellur 2011-03-10 08:09:50 EST
PATCH: http://patches.gluster.com/patch/6381 in master (mgmt/glusterd: gluster profile implementation)
Comment 5 Vijay Bellur 2011-03-10 08:09:54 EST
PATCH: http://patches.gluster.com/patch/6382 in master (glusterfsd: translator info event handling implementation)
Comment 6 Vijay Bellur 2011-03-10 08:09:57 EST
PATCH: http://patches.gluster.com/patch/6383 in master (libglusterfs: Add sort routine)
Comment 7 Vijay Bellur 2011-03-10 08:10:01 EST
PATCH: http://patches.gluster.com/patch/6384 in master (cli: gluster profile CLI)

Note You need to log in before you can comment on or make changes to this bug.