Bug 763698 - (GLUSTER-1966) Unnecessarily verbose logs at the default log level
Unnecessarily verbose logs at the default log level
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-15 19:36 EDT by Vikas Gorur
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vikas Gorur 2010-10-15 19:36:49 EDT
The glusterd log has messages such as:

[2010-10-15 16:23:07.740393] I [glusterd-op-sm.c:5061:glusterd_op_sm_inject_even
t] glusterd: Enqueuing event: 'GD_OP_EVENT_ALL_ACC'
[2010-10-15 16:23:07.740403] I [glusterd-op-sm.c:4740:glusterd_op_sm_transition_
state] : Transitioning from 'Unlock sent' to 'Unlock sent' due to event 'GD_OP_E
VENT_RCVD_ACC'
[2010-10-15 16:23:07.740412] I [glusterd-op-sm.c:5109:glusterd_op_sm] : Dequeued
 event of type: 'GD_OP_EVENT_ALL_ACC'
[2010-10-15 16:23:07.740423] I [glusterd-op-sm.c:4561:glusterd_op_txn_complete] 
glusterd: Cleared local lock
[2010-10-15 16:23:07.740458] I [glusterd-op-sm.c:4740:glusterd_op_sm_transition_
state] : Transitioning from 'Unlock sent' to 'Default' due to event 'GD_OP_EVENT
_ALL_ACC'

These make no sense to a user, and should not be logged under the default log level. These messages are more appropriate at the DEBUG or TRACE level.
Comment 1 Anand Avati 2010-10-29 03:42:21 EDT
PATCH: http://patches.gluster.com/patch/5601 in master (cli,mgmt/glusterd: fsm log implementation)
Comment 2 Pranith Kumar K 2010-11-09 01:02:36 EST
implemented hidden commands fsm log [<peer-name>] and marked these logs to DEBUG level to fix the issue

Note You need to log in before you can comment on or make changes to this bug.