Bug 76371 - Broken Japanese .po file
Summary: Broken Japanese .po file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL: http://bioinfo.jaist.ac.jp:8000/~tais...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-21 01:45 UTC by Taishin Kin
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-21 01:45:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Taishin Kin 2002-10-21 01:45:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020919

Description of problem:
rhn-applet fails to show "Terms of Service" due to broken Japanese .po file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Right-click RHN button which resides in Gnome panel
2.Select "Property..." to run "Red Hat Network Alert Notification Tool"
3.Click "Next" button to proceed to "Terms of Service" dialog
	

Actual Results:  "Terms of Service" shows unreadable text.

Expected Results:  "Terms of Service" should show clear text.

Additional info:

This bug is due to broken
/usr/share/locale/ja/LC_MESSAGES/rhn-applet.mo
file.
I tried to "cat" it on a console (i.e. gnome-terminal).
However, the first Japanese message cannot be shown while the following messages
are shown without any problem.

Comment 1 Chip Turner 2002-11-05 00:17:43 UTC
this is a result of gtkhtml not properly supporting UTF8, and is fixed in 8.0

Comment 2 Chip Turner 2002-11-05 00:18:05 UTC
*** Bug 76335 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.