Bug 76375 - Text fields do not have a focus outline
Text fields do not have a focus outline
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gtk2 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-20 23:32 EDT by Brian Ryner
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-20 23:32:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian Ryner 2002-10-20 23:32:00 EDT
Description of Problem:

When you focus a text field by clicking on it or tabbing to it, in a gtk2 app,
the text field doesn't have a focus outline.  Not sure if this is intentional,
but I suspect not, as it could be an issue for accessibility.

Version-Release number of selected component (if applicable):

gtk-2.0.6-8

How Reproducible:

always

Steps to Reproduce:
1. Focus a text field in a gtk2 app by clicking on it or tabbing to it
2. 
3. 

Actual Results:

No focus outline appears

Expected Results:

A focus outline should appear on the text field.

Additional Information:
	
It doesn't seem to matter which theme I use; I see this on all of the included
GTK2 themes.  However, with BlueCurve on GTK 1.x applications, a focus outline
appears as expected.
Comment 1 Owen Taylor 2002-10-31 17:45:47 EST
This is working as intended. Similar to the way it works in  
Microsoft Windows the focus is indicated by one of:

 - The presence of the cursor
 - The selected text being displayed in a more vibrant color.

(It's possible for a theme to specify a more Motif-like way of 
 drawing the focus)

Note You need to log in before you can comment on or make changes to this bug.