Bug 763811 - (GLUSTER-2079) [glusterfs-3.1.1qa5]: crash in afr_local_cleanup
[glusterfs-3.1.1qa5]: crash in afr_local_cleanup
Status: CLOSED DUPLICATE of bug 763793
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.1.0
All Linux
low Severity high
: ---
: ---
Assigned To: Pavan Vilas Sondur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-10 09:45 EST by Raghavendra Bhat
Modified: 2010-12-23 04:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: DNR
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Bhat 2010-11-10 09:45:04 EST
nfs server crashed. Operations being performed:

1) 2 replica volume

2) 1 fuse mount and 1 nfs mount

3) linux kernel untarring on fuse mount

4) rm -rf of the untarred kernel on the nfs mount

5) find /nfs | xargs stat on nfs mount

6) did remove brick and add brick


This is the backtrace of the core generated.



Core was generated by `/usr/local/sbin/glusterfs -f /etc/glusterd/nfs/nfs-server.vol -p /etc/glusterd/'.
Program terminated with signal 11, Segmentation fault.
#0  pthread_spin_lock (lock=0xaaaaaac2) at ../nptl/sysdeps/x86_64/../i386/pthread_spin_lock.c:35
35	../nptl/sysdeps/x86_64/../i386/pthread_spin_lock.c: No such file or directory.
	in ../nptl/sysdeps/x86_64/../i386/pthread_spin_lock.c
(gdb) bt
#0  pthread_spin_lock (lock=0xaaaaaac2) at ../nptl/sysdeps/x86_64/../i386/pthread_spin_lock.c:35
#1  0x00007f3d36af679b in fd_unref (fd=0x7f3d32219024) at ../../../libglusterfs/src/fd.c:467
#2  0x00007f3d34564073 in afr_local_cleanup (local=0x195a280, this=0x18b71b0) at ../../../../../xlators/cluster/afr/src/afr-common.c:367
#3  0x00007f3d3453e506 in afr_fstat_cbk (frame=0x7f3d3547c8e8, cookie=<value optimized out>, this=<value optimized out>, 
    op_ret=<value optimized out>, op_errno=<value optimized out>, buf=<value optimized out>)
    at ../../../../../xlators/cluster/afr/src/afr-inode-read.c:351
#4  0x00007f3d3479affd in client3_1_fstat_cbk (req=<value optimized out>, iov=<value optimized out>, count=<value optimized out>, 
    myframe=0x7f3d3547c75c) at ../../../../../xlators/protocol/client/src/client3_1-fops.c:1028
#5  0x00007f3d368b6a45 in rpc_clnt_handle_reply (clnt=0x18c05e0, pollin=0x18fabd0) at ../../../../rpc/rpc-lib/src/rpc-clnt.c:752
#6  0x00007f3d368b6c99 in rpc_clnt_notify (trans=<value optimized out>, mydata=0x18c0610, event=<value optimized out>, data=0x7f3d36489280)
    at ../../../../rpc/rpc-lib/src/rpc-clnt.c:865
#7  0x00007f3d368b1e9d in rpc_transport_notify (this=0xaaaaaac2, event=<value optimized out>, data=<value optimized out>)
    at ../../../../rpc/rpc-lib/src/rpc-transport.c:1142
#8  0x00007f3d31d579a4 in socket_event_poll_in (this=0x18c0700) at ../../../../../rpc/rpc-transport/socket/src/socket.c:1619
#9  0x00007f3d31d57a73 in socket_event_handler (fd=<value optimized out>, idx=0, data=0x18c0700, poll_in=1, poll_out=0, 
    poll_err=<value optimized out>) at ../../../../../rpc/rpc-transport/socket/src/socket.c:1733
#10 0x00007f3d36af8762 in event_dispatch_epoll_handler (event_pool=<value optimized out>) at ../../../libglusterfs/src/event.c:812
#11 event_dispatch_epoll (event_pool=<value optimized out>) at ../../../libglusterfs/src/event.c:876
#12 0x0000000000405597 in main (argc=7, argv=0x7fff631a7cd8) at ../../../glusterfsd/src/glusterfsd.c:1414
(gdb) p fd->inode
No symbol "fd" in current context.
(gdb) f 1
#1  0x00007f3d36af679b in fd_unref (fd=0x7f3d32219024) at ../../../libglusterfs/src/fd.c:467
467	        LOCK (&fd->inode->lock);
(gdb) p fd->inode
$1 = (struct _inode *) 0xaaaaaaaa
(gdb) 

(gdb) f 8
#8  0x00007f3d31d579a4 in socket_event_poll_in (this=0x18c0700) at ../../../../../rpc/rpc-transport/socket/src/socket.c:1619
1619	                ret = rpc_transport_notify (this, RPC_TRANSPORT_MSG_RECEIVED,
(gdb) p this
$13 = (rpc_transport_t *) 0x18c0700
(gdb) f 7
#7  0x00007f3d368b1e9d in rpc_transport_notify (this=0xaaaaaac2, event=<value optimized out>, data=<value optimized out>)
    at ../../../../rpc/rpc-lib/src/rpc-transport.c:1142
1142	                ret = this->notify (this, this->mydata, event, data);
(gdb) p this
$14 = (rpc_transport_t *) 0xaaaaaac2
(gdb)
Comment 1 Raghavendra Bhat 2010-11-10 21:00:12 EST

*** This bug has been marked as a duplicate of bug 2061 ***
Comment 2 Shehjar Tikoo 2010-11-10 21:17:24 EST
How are you so sure this is a duplicate of 2079? There are no add-brick,remove-brick operations happening on that test. Its a simple readdir on dht.
Comment 3 Raghavendra Bhat 2010-11-10 21:48:47 EST
Here also it is crashing while trying to do fd_unref.

Note You need to log in before you can comment on or make changes to this bug.