Bug 76385 - 2.4.18-17.7.x update breaks Wacom tablet support
2.4.18-17.7.x update breaks Wacom tablet support
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-10-21 03:48 EDT by Ondrej X Dolezal
Modified: 2008-08-01 12:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:40:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ondrej X Dolezal 2002-10-21 03:48:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
After upgrade to the 2.4.18-17 kernel, my Wacom PenPartner (serial) 
tablet stopped working in XFree86 (it never worked in console anyway). 
Gnome startup is very slow (about 1 minute on 1GHz/256MB machine, 
used to be 10 seconds) and XFree86 fills log with lines:
"Wacom unable to read first byte of request '~#' answer after 3 tries"
(about 80 of them). The log does not contain any other warning or error messages
from any module.
I have 2 machines with nearly identical setup,
both using RH7.3 with all errata & Wacom PenPartner - same results
on both.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. connect & configure Wacom PenPartner for XFree86-4.2.0
2. upgrade to 2.4.18-17.7.x
3. launch gnome

Actual Results:  Computer response is very slow for about a minute, tablet does
not work.

Expected Results:  Normal speed and a working tablet.

Additional info:

HW: Celeron 950MHz, 256MB RAM, i815E chipset with onboard sound,
GeForce 2MX video (same results using both "nv" and "nvidia" XFree driver),
Realtek 8139 ethernet, Seagate 40GB drive on UDMA cable, Teac CD-Writer

SW: RH7.3 with complete errata, kernel 2.4.18-17, XFree86-4.2.0, czech locale
Comment 1 Alex Tucker 2002-10-30 14:54:34 EST
I have the same problem with my wacom tablet and kernel 2.4.18-14 that comes  
with RH8.  If I switch to an older kernel 2.4.18-4 for instance, the tablet  
works fine.
Comment 2 Arjan van de Ven 2002-11-16 06:07:05 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

Comment 3 Ondrej X Dolezal 2002-11-18 07:50:35 EST
The problem persists even with the newest kernel 2.4.18-18.7 from errata.
The only way to use a serial wacom tablet now is to run kernel 2.4.18-10 or lower.
Comment 4 Paul Koshevoy 2002-11-18 17:24:50 EST
I have the exact same problem: 
RedHat 7.3 on dual P3-866. My serial Wacom Intuos 9x12 
worked fine with kernel-2.4.18-10, stopped working after  
upgrading to kernel-2.4.18-17.7.x and kernel-2.4.18-18.7.x. 
An excerpt from /var/log/XFree86.0.log follows: 
(II) XINPUT: Adding extended input device "eraser0" (type: Wacom Eraser) 
(II) XINPUT: Adding extended input device "pen0" (type: Wacom Stylus) 
(II) XINPUT: Adding extended input device "cursor0" (type: Wacom Cursor) 
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE) 
(**) Option "Device" "/dev/ttyS0" 
(**) Option "StopBits" "1" 
(**) Option "DataBits" "8" 
(**) Option "Parity" "None" 
(**) Option "Vmin" "1" 
(**) Option "Vtime" "10" 
(**) Option "FlowControl" "Xoff" 
Wacom unable to read first byte of request '~#' answer after 3 tries 
Wacom unable to read first byte of request '~#' answer after 3 tries 
I suspect the fault actually is in the wacom_drv.o for XFree86, 
because I can't imagine serial port support being broken in a 
stable kernel. Perhaps the WACOM XFree86 input driver is not  
initializing the serial port properly? 
Comment 5 Alex Tucker 2002-11-19 17:14:29 EST
I upgraded to 2.4.18-17.8.0 and now my *usb* wacom tablet works again, thanks.
Comment 6 Need Real Name 2002-11-24 21:20:49 EST
I have a *serial* Intuos Wacom tablet which was working fine with RedHat 7.2 and
7.3 (stock kernels). After I installed RedHat 8.0 the support was broken, and I
was getting the error message already listed above:

Wacom unable to read first byte of request '~#' answer after 3 tries

My RedHat 8.0 was coming with the kernel 2.4.18-14. Even after updating to
2.4.18-18.8.0 the tablet is still not working, X is considerably slowed down and
I get over and over the above error message.

My graphic card is an NVidia GeForce4, and the problem persists with both the
"vesa" and the proprietary "nvidia" driver.
Comment 7 lewing 2002-12-03 02:48:20 EST
I have serial Intuos 9x12 with the same problem on kernel-2.4.18-18.7.x, haven't
tried an older kernel yet but I definitely had the tablet working previously on
7.2 or 7.3 (not sure on the timeline).  If I use the wacom_drv.o from
http://people.mandrakesoft.com/~flepied/projects/wacom/ I can get the tablet to
respond again but there are huge jumps that seem like they migh be related to
disk i/o
Comment 8 Ondrej X Dolezal 2002-12-03 05:25:49 EST
The tablet works again using the above mentioned updated wacom_drv.o,
thank you.

This seems like the problem was really in the XFree wacom module and not
in the kernel, but as the problem started with kernel update it looked
unprobable to me.

IMHO the driver should be updated in the XFree86 package so tablet can work 
in new and updated RH7.3 and 8.0.
Comment 9 lewing 2003-02-15 22:00:50 EST
Ok I isolated the large jump problem.  It was being caused by the gnome battery
applet reading from /proc/apm.  It appears that at least on some dell laptops
reading the apm info causes the kernel to miss interrupts.  This was causing my
system clock to lose time, causing the wacom driver to get bad serial data and
causing a usb camera to get corrupt data/lose frames.  Removing the battery
applet stops this behavior.

I've confirmed the problem on and Dell Inspiron 4150 and a dell Inspiron 8200.
Comment 10 Bugzilla owner 2004-09-30 11:40:06 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.