This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 763983 - (GLUSTER-2251) NFS server hangs on 40 dds running in parallel
NFS server hangs on 40 dds running in parallel
Status: CLOSED DUPLICATE of bug 764052
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
pre-2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-28 01:33 EST by Prasanth
Modified: 2011-01-27 03:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTP
Mount Type: nfs
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shehjar Tikoo 2010-12-27 22:43:06 EST
Please use accurate wording when filing a bug. NFS wasnt crashing anywhere in the tests that we conducted. The whole machine was freezing...two very different situations.
Comment 1 Prasanth 2010-12-28 01:33:58 EST
Hi,

This bug is opened based on the ticket: http://support.gluster.com/rt/Ticket/Display.html?id=2504

---
The Gluster native NFS crashes when mounted locally over localhost and handling many parallel writes. 40 parallel "dd if=/dev/zero of=/nfsmount/inX.dat bs=1M" are started and the dd processes quickly hangs together with the NFS mount.
---

I could reproduce this issue inhouse while doing 40+ parallel dd's. The server itself get hanged while doing parallel writes in the mount point. Unable to run any commands after that and a reboot is required to bring the server back online.

Regards,
Prasanth
Comment 2 Shehjar Tikoo 2011-01-27 00:31:42 EST
More information available at 2251.

*** This bug has been marked as a duplicate of bug 2320 ***

Note You need to log in before you can comment on or make changes to this bug.