Bug 76408 - (G450) xinerama and true type fonts broken
(G450) xinerama and true type fonts broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-21 10:29 EDT by daniel
Modified: 2007-04-18 12:47 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-17 16:01:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daniel 2002-10-21 10:29:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Running a dual head solution (G450 video card and xinerama) and turning true
type fonts on results in corupted fonts in XF86. The result is viewable in both
gnome and kde. Bottons and icons will loose their text, scolling in a file
browser (like konqueror) on screen one will pollute screen 2 with overlayed text
that can only be cleared by dragging another window over it.  Fonts look great,
really great in this release, I just hope this is a problem that can be
resolved.  I have also seen this problem posted to usenet groups as well (
http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&threadm=c6c8a918.0210131708.2cf50d11%40posting.google.com&rnum=5&prev=/groups%3Fq%3Dxinerama%2Bredhat%2B8.0%26ie%3DUTF-8%26oe%3DUTF-8%26hl%3Den
   )

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run dual head (G450 + xinerama)
2.Leave trutype on (which is default) in kde (or gnome)
3.Open file browser (konqueror) on screen one, use scrollbars on directory with
many files and watch screen two become polluted with text, drag mouse over
desktop icons on screen one and see thier text dissapear and reapear on screen two.
	

Actual Results:  Text becomes unpredictable and dissapears/reapears on the wrong
desktopn or not at all.

Expected Results:  Should behave as it does with only one monitor activated.

Additional info:
Comment 1 Mike A. Harris 2002-10-23 12:12:59 EDT
This is a known flaw in the mga driver when using dualhead with xinerama.
You can use:  Option "noaccel" as a workaround for now until someone
fixes the mga driver.  Or you can experiment with the various
XaaNo options described in "man XF86Config"

Comment 2 Jacques Supcik 2002-10-24 05:32:34 EDT
Thank you to mharris@redhat.com for his comment.
As advised, I've tried the different XaaNo options and I found that, in my case,
the "XaaNoOffscreenPixmaps" solved the problem.
Comment 3 daniel 2002-10-24 11:11:07 EDT
Unfortunately, this does not work for me. I believe this is a fix for gnome, but
i use kde. The noaccel fixes the problem at the price of making the desktop
unusable without accelleration.  I have been following the linux forums at
matrox, and they are aware of the problem.
Comment 4 Need Real Name 2002-11-06 10:21:24 EST
matrox now appears to be looking into the problem -- see the linux section in
their tech support forum...
Comment 5 Mike A. Harris 2002-11-07 07:09:02 EST
I have no idea what or where the Matrox tech support forum is.

If there is any new information for this particular problem, or any suggested
patch or fix, please attach it directly to this bugzilla report.
Comment 6 Jason Merrill 2002-11-08 16:10:06 EST
The Matrox Linux tech support forum is at

http://forum.matrox.com/cgi-bin/mgaforum/forumdisplay.cgi?action=topics&forum=Linux&number=2

"XaaNoOffscreenPixmaps" works for me under gnome with a G400 and Red Hat Linux 8.0.
Comment 7 Mike A. Harris 2002-11-24 02:18:07 EST
Please download and test the following driver:

Rename your existing driver /usr/X11R6/lib/modules/drivers/mga_drv.o
to mga_drv.o.orig first, then put the new one in place. Then edit
your config file, and remove any options that disable acceleration, 
etc.

ftp://people.redhat.com/mharris/test-drivers/mga_drv.o

Test it fully until you are sure it works or does not work.  Once I've
gotten feedback from that, I can explore the problem deeper, and try
to possibly fix the root cause (Even though I do not have Matrox G450
documentation - but they do.)

Hope this helps.
Comment 8 Need Real Name 2002-11-24 14:02:35 EST
This driver did not work for me (Matrox 550).  Here's the exerpt from the
XFree86.0.log:

(II) LoadModule: "mga"
(II) Loading /usr/X11R6/lib/modules/drivers/mga_drv.o
(II) Module mga: vendor="The XFree86 Project"
        compiled for 4.2.99.2, module version = 1.1.0
        Module class: XFree86 Video Driver
        ABI class: XFree86 Video Driver, version 0.6
(EE) module ABI minor version (6) is newer than the server's version (5)
(II) UnloadModule: "mga"
(II) Unloading /usr/X11R6/lib/modules/drivers/mga_drv.o
(EE) Failed to load module "mga" (module requirement mismatch, 0)
Comment 9 Denice 2002-11-25 08:26:23 EST
Looks like one needs to have a rawhide system to try this new driver.  Since I
already had an early set of rawhide XFree86 rpms installed I decided to really
messed up my system by updating rawhide bits on it (like kernel, glibc, etc.).

Now I have hardware accel. again.  Long-listing a big set of files in an xterm,
for example, is orders of magnitude faster.  I have NO font problems, which I
had big-time with the original 8.0 rpms and pretty much any X configuration.

However the left-hand screen-image  (I have 2 Dell 2000FP flat panels) insists
on dropping down to 1600x1200 @ 57 Hz instead of 1600x1200 @ 60 Hz.  When I
switch the connections around the problem follows the left-hand half of the
image -- ie, when I switch the connections between the monitors suddenly it is
the right-hand monitor that reports 57 Hz.

This was an occasional problem with the old driver that could be fixed by
ALT-Consoling out and back into graphics.  However now I can't get rid of it. 
If anyone has any suggestions on how to treat this it would be great.  The left
hand image flickers ever so slightly, and occasionally blanks off and on. It's
extremely annoying.  [When I get a moment I'll install another G450 card just to
verify that it isn't the card.]
Comment 10 daniel 2002-11-25 09:18:47 EST
I get the same "module ABI minor version (6) is newer than the server's version
(5)" with my system.  I scanned rawhide but didn't see any Xfree packages.  What
is the minimum set of rawhide packages needed to run this (kernel,glibc,etc)? 
Is it posible to compile this for a stock 8.0 system, or is the source in a
state that one could compile it himself without to much trouble?
Comment 11 Denice 2002-11-25 09:43:30 EST
Example up-to-date rawhide site with Xfree stuff:
 ftp://sunsite.auc.dk/mirrors/redhat/rawhide/i386/RedHat/RPMS/

I wouldn't recommend updating to the rawhide stuff unless you're installation is
expendable.  The Xfree stuff in rawhide depends on kernel-drm...[and my machine
died hard on starting apache, which I lazily did not update]. I would wait and
see what Mike suggests..
Comment 12 Denice 2002-11-28 09:16:43 EST
OK, I finally had an opportunity to install another G450 card, and my uneven
frequencies between image halves has disappeared.  Hmmm. strange. Anyway, maybe
I can use the card with some of the 21" Dell P1110's, where higher frequencies
would probably mask the problem. Flat panel screens can sometimes be annoying;
they are more sensitive and less happy about being manually adjusted (though I
must say that my 2000FP's look nice side by side with an 'alien-night' backdrop
in xinerama mode :-)

In short, this driver works for me.  I'm always happy to be a guinea pig for
further testing.
Comment 13 Need Real Name 2002-11-28 10:11:42 EST
This driver sounds good, could we have a RH8 compliant version ? I can't wait to
test it, but I cannot take the risk to break my current linux installation :(
Comment 14 Mike A. Harris 2002-12-17 16:01:39 EST
I've tested the latest build 20021217 on the hardware I have here
and am unable to reproduce this problem now.  I'm closing this now as
fixed in RAWHIDE XFree86-4.2.99.2-20021217.

If enough people test it to convince me it is safe to include the same fix
in erratum for 4.2.1 in RHL 8.0, I may add this to the next erratum.

Note You need to log in before you can comment on or make changes to this bug.