Bug 76410 - memory leak causes swap file to max and crashes system
memory leak causes swap file to max and crashes system
Status: CLOSED DUPLICATE of bug 76219
Product: Red Hat Linux
Classification: Retired
Component: Xft (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-21 10:33 EDT by joe briggs
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joe briggs 2002-10-21 10:33:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Switch desktop from Gnome to KDE and back to Gnome. Then each instance of
gnome-terminal starts gobbling up memory eventually causing swap file to fill up
completely, slowing response to look crashed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH 8.0 workstation with both Gnome & KDE.
2.Switch sessions to KDE and then back to Gnome.
3.Start system monitor to monitor processes & memory.
3.Launch gnome-terminal and do stuff. 
4.Notice that memory allocated to gnome-terminal starts increasing 60 MB, 80 MB,
140 MB, ....
5. Notice that as memory consumption increases that swap file starts to fill.
6.  System response starts to slow down.
7. Killing gnome-terminal fails to release swap space.
	

Actual Results:  System response slows down to appear crashed.
Killing gnome-terminal does not release main memory or swap space.

Expected Results:  Memory consumption for gnome-terminal should remain flat.
Memory should be returned to system after process termination.
Swap space should recover after process termination.

Additional info:
Comment 1 Nalin Dahyabhai 2002-10-21 12:38:00 EDT
If you run "xdpyinfo", is RENDER one of the listed extensions?
Comment 2 joe briggs 2002-10-21 12:58:58 EDT
RENDER is NOT one of the extensions shown when I run xdpyinfo.
Comment 3 Neal Neuburger 2002-11-02 09:41:43 EST
The memory leak can also be observed if:
1. gnome-terminal is invoked from a Sun/solaris X-display server.
2. gnome-terminal is invoked from VNC.

In both cases an error message is displayed (on the invoking termin (Sun) or in the VNC logs:
Xlib: extension "RENDER" is missing on display
Comment 4 David Petruzzella 2002-12-01 17:09:30 EST
Actually the bug to me anyway seems to be more noticeable when using vnc, I've
even tried checking the settings of my terminal sessions following a few
suggestions from research I have done and I don't see an alternative way around
the bug (unless another desktop is used).  Any idea when a resolution may come
about or a way to bypass the bug, until it is resolved?
Comment 5 Havoc Pennington 2002-12-01 17:21:31 EST
It's possible that disabling antialiasing would avoid the bug, 
though I'm not sure. We need an Xft update for it, it's an Xft bug.

(All apps using Xft should in fact have the leak - including all GNOME and KDE
apps - g-t seems to just draw more text than most apps.)
Comment 6 David Petruzzella 2002-12-01 17:30:38 EST
If it makes any difference in redhat 7.3 I did not see this problem, I could
have more than 1 gnome-terminal opened for days on end without any problems.
Comment 7 David Petruzzella 2002-12-01 17:33:00 EST
What are the steps to disabling antialiasing? I could try it out and see what
results.
Comment 8 Owen Taylor 2003-01-07 15:47:47 EST

*** This bug has been marked as a duplicate of 76219 ***
Comment 9 Red Hat Bugzilla 2006-02-21 13:50:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.