Bug 764168 - (GLUSTER-2436) Not able to send error reply in nfs_rpcsvc
Not able to send error reply in nfs_rpcsvc
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.1.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Gaurav
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-16 07:02 EST by Gaurav
Modified: 2015-12-01 11:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaurav 2011-02-16 07:02:54 EST

    
Comment 1 Anand Avati 2011-03-01 02:06:08 EST
PATCH: http://patches.gluster.com/patch/6293 in master (NFS : Send error reply on rpc decoding failure.)
Comment 2 Saurabh 2011-03-08 22:11:27 EST
Gaurav, can you please update the target milestone and the testplan for this bug.
Comment 3 Gaurav 2011-03-08 22:23:41 EST
To verify this bug, you need to send corrupted rpc packet from NFS client. We should be able to send error reply with GARBAGE_ARGS. I am not sure how would you do this, since we don't have any tool to change the on wire packets.
Comment 4 Saurabh 2011-03-09 05:56:46 EST
creating a corrupted packet is corner case and hence leaving this bug in same state as it is and will reopen if something of this sort happens again.

Note You need to log in before you can comment on or make changes to this bug.