Bug 764189 - (GLUSTER-2457) remove-brick command should migrate data
remove-brick command should migrate data
Status: CLOSED DUPLICATE of bug 763684
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
All All
low Severity low
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 13:52 EST by William L. Sebok
Modified: 2013-12-18 19:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description William L. Sebok 2011-02-23 13:52:49 EST
There should be and option in "remove-brick" command (or some similar command) to migrate the data in a brick to other bricks before removing that brick. This would be *extremely* useful in dealing with a distributed/replicated filesystem with a computer and/or brick that is dead or likely to be down for an extended period (I configure bricks to be replicated between different computers). The remove-brick command on startup could make an estimate whether the data would fit on the remaining bricks. If after the migration started it turned out that the data really does not all fit there would still would not be any loss as long as the last file movement wasn't completely committed.  The command then could be aborted.
Comment 1 Amar Tumballi 2011-07-06 05:21:32 EDT

*** This bug has been marked as a duplicate of bug 1952 ***

Note You need to log in before you can comment on or make changes to this bug.