Bug 76424 - MD5 Error but Successful install
Summary: MD5 Error but Successful install
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-21 16:50 UTC by jhosage
Modified: 2015-01-08 00:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-04 18:40:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/up2date file - last entries (1.97 KB, text/plain)
2002-10-21 16:53 UTC, jhosage
no flags Details

Description jhosage 2002-10-21 16:50:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
While running the up2date GUI installer, an MD5 error message was displayed in
the console.  However the final summary page indicated all installed correctly.
 The error message is:

[root@ferdinand conf]# up2date
error: rpmts_HdrFromFdno: MD5 digest: BAD
Expected(46dbe5e58ff89f16978689c3385bde11) != (17751cb76fa32751f65e5ae2be02b3d5)

The packages installed where:

The Red Hat Update Agent has finished installing
 the following packages successfully:

hwdata-0.48-1
mozilla-1.0.1-26
mozilla-nspr-1.0.1-26
mozilla-nss-1.0.1-26
mozilla-psm-1.0.1-26

The last entries in /var/log/up2date are attached.



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Comment 1 jhosage 2002-10-21 16:53:20 UTC
Created attachment 81367 [details]
/var/log/up2date file - last entries

Comment 2 Adrian Likins 2002-11-01 22:12:46 UTC
looks like a librpm issue, reassigning to rpm

Comment 3 Jeff Johnson 2002-11-02 15:33:45 UTC
The error message is coming from mozilla:

mozilla-1.0.1-26.i386.rpm:
    Header V3 DSA signature: OK, key ID db42a60e
    Header SHA1 digest: OK (fe02024782cca0c9e569000546d27b01af163730)
    MD5 digest: OK (46dbe5e58ff89f16978689c3385bde11)
    V3 DSA signature: OK, key ID db42a60e

What does
	cd /var/spool/up2date
	rpm -Kvv mozilla-1.0.1-26.i386.rpm
say? If that passes, then there are no obvious
(to me) rpmlib issues.

I am confused, however, why the MD5 is being calculated
at all, as there is a DSA signature on the package. The
choice of what package signatures/digests to calculate
when is an up2date, not rpm, coding issue.

So what is the rpmlib issue?


Comment 4 jhosage 2002-11-04 18:40:49 UTC
I can't perform the "rpm -Kvv" command on the rpm package in /var/spool/up2date.
 As shown in the attached log, the package was deleted after the install.

Comment 5 Adrian Likins 2002-11-04 21:46:29 UTC
Sounds like you just got a corrupted package on download. up2date runs
a md5sum check on packages to see if they are complete and not corrupt. 
If this check fails, you get a error message like the above, and then
up2date downloads the package again. So the message is a warning,
and is harmless.


Note You need to log in before you can comment on or make changes to this bug.