Bug 764296 - (GLUSTER-2564) replace brick fails on master
replace brick fails on master
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.1-alpha
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-20 04:52 EDT by Pranith Kumar K
Modified: 2011-06-10 08:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2011-03-20 04:52:39 EDT
Because the stop glusterfs is resetting the port, the restart brick is starting the brick on some other port because of which the client is not connecting.

Pranith.
Comment 1 Vijay Bellur 2011-03-20 06:01:38 EDT
PATCH: http://patches.gluster.com/patch/6521 in master (mgmt/glusterd: Dont reset the port on brick stop)
Comment 2 Raghavendra Bhat 2011-06-10 05:10:14 EDT
Replace brick succeeded from the master.

Note You need to log in before you can comment on or make changes to this bug.