Bug 76431 - nscd crashes system under moderate load
nscd crashes system under moderate load
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nscd (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-21 14:39 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 16:37:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-21 14:39:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020916

Description of problem:
nscd leaves too many open file descriptors.  there are plenty of fd's left in
/proc/sys/file-nr, yet the system logs errors to syslog and refuses to allocate
fd's to other processes.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. heavy load (user queries plus rdns queries).
2. nss-mysql module installed for authentication
(http://savannah.nongnu.org/projects/nss-mysql).
3. nss-mysql requires 1 fd per auth per user.
	

Additional info:

nscd-2.2.4-30

Red Hat Linux release 7.2 (Enigma)

all available eratta installed.
Comment 1 Jakub Jelinek 2004-10-02 16:37:06 EDT
nscd changed a lot since then, if you are able to reproduce this
with Fedora Core 3 test2, please reopen.

Note You need to log in before you can comment on or make changes to this bug.