Bug 7644 - GNOME terminal corrupts its display
GNOME terminal corrupts its display
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: termcap (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-06 19:01 EST by Damien Miller
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-05 13:23:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damien Miller 1999-12-06 19:01:54 EST
gnome-terminal frequently corrupts its display, replacing a line of text
with a bolded '~' character in the leftmost column. This appears to happen
at random.
Comment 1 Elliot Lee 2000-01-17 15:16:59 EST
Any instructions on how to reproduce?

Please make sure you have the 6.1 errata installed, specifically for gnome-libs
and gnome-core.
Comment 2 Damien Miller 2000-01-17 16:55:59 EST
I have installed the errata since the initial report and the problem still
happens. I am not sure how to reproduce it, it appears to happen pretty much at
random though any sort of vt100 cursor movement codes will increase the
likelihood of it happening.
Comment 3 johnchik 2000-01-27 16:06:59 EST
I have recently upgraded to Nethack 3.3.0 and I finally managed to get it to run
in the GNOME terminal.  At random, I also see a row of ~ while I play the game
in tty mode (I really don't like the X11/tile version).  It seem to occur
particularly when you move from level to level (ie. going up and down the
stairs).  At random a row of "."'s (which represent floor) are replace with
"~"'s.  Also bits of the walls are replaced by letters.  It seems to get worse
if you repeatedly go up and down the stairs.  I have thought that this was a
Nethack problem, but the game seems to be OK if I don't use X (& GNOME).
However is you save the game and return to it later, the random "~"'s and
letters are still there.  Hopefully this is of some help.  I will look at it
again myself.

John

P.S.  I did install the newest version of gnome-core and gnome-lib
P.P.S. Nethack options=tty,DECgraphics etc...
Comment 4 Preston Brown 2000-02-16 10:40:59 EST
I think this is most likely a termcap issue.

Note You need to log in before you can comment on or make changes to this bug.