Bug 76450 - .htaccess protected documents produce "The document contains no data." errors.
.htaccess protected documents produce "The document contains no data." errors.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-21 19:01 EDT by Carl T. Miller
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 11:47:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl T. Miller 2002-10-21 19:01:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
After setting up .htaccess files, configuring /etc/httpd/conf/httpd.conf and
restarting httpd, files will not open and a message says "The document contains
no data."

/var/log/httpd/errors says:
[notice] child pid 20731 exit signal Segmentation fault (11)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create html document in a new directory, test that it gets delivered correctly
2. in /etc/httpd/conf/httpd.conf, set AllowOverride All in <Directory /> and
<Directory "/var/www/html">
3. run htpasswd -c /etc/httpd/users test
4. run chown apache:apache /etc/httpd/users
5. in the directory with the webpage, create a .htaccess file:

AuthType Basic
AuthName "Enter your name and password."
AuthUserfile /etc/httpd/users
require user test

6. run service httpd restart
7. try to open the page

Actual Results:  Get a popup error message saying "The document contains no data."

Expected Results:  Should have been prompted for a username and password.

Additional info:

/var/log/httpd/errors says:
[notice] child pid 20731 exit signal Segmentation fault (11)
Comment 1 Carl T. Miller 2002-10-29 19:47:29 EST
After verifying that this does work correctly on another server, I reinstalled
the OS, and now it works correctly.
Comment 2 Carl T. Miller 2002-11-18 18:01:07 EST
I'll take it back.  I still have a problem on my web server.

I reinstalled everything again, and I'm seeing the exact same results as
described above.  What I find interesting is that if I deny/allow by IP address
and try to open from an allowed address, it works.  If I try to open from a
denied addess, I get the "Document contains no data" message.

I'm starting to wonder if this has anything to do with specific hardware.  The
server has dual Pentium IIs, and I'm running the latest i686 kernel from Red Hat.

Let me know if I can send you anything that could help you troubleshoot this.
Comment 3 Joe Orton 2003-01-22 11:46:03 EST
I could never reproduce this; can you attach your httpd.conf and error_log? 
What was the specific path to the .htaccess file you used?
Comment 4 Joe Orton 2005-01-25 11:47:11 EST
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

c) report the bug to the Fedora Legacy project who may wish to
continue maintenance of this package.

Note You need to log in before you can comment on or make changes to this bug.