Bug 76452 - remote servers deny email from server with unroutable IP address
remote servers deny email from server with unroutable IP address
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-10-21 19:17 EDT by Carl T. Miller
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-04 16:09:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Carl T. Miller 2002-10-21 19:17:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
My server has an unroutable address and it uses a router/masquerader to connect
to the Internet.  When I try to send email to another server, it is rejected
with the following error: Relaying denied. IP name possibly forged []

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. run mail -v carl@carltm.com

Actual Results:  Snippets from the output:

>>> EHLO computer.carltm.com
250- carltm.com Hello computer.carltm.com [] (may be forged), pleased to
meet you

>>> MAIL From:<root@computer.carltm.com> SIZE=53
250 2.1.0 <root@computer.carltm.com>... Sender ok
>>> RCPT To:<carl@carltm.com>
>>> DATA
550 5.7.1 <carl@carltm.com>... Relaying denied. IP name possibly forged []

Expected Results:  It should have said "Recipient ok" and accepted the message.
 I have already sent email from another server to verify that the remote server
is not misconfigured.

Additional info:

Is there a way in the sendmail.cf I can either tell it not to send its IP
address or give it the address of the router/masquerader?
Comment 1 Carl T. Miller 2002-10-27 19:39:04 EST
I've solved the problem.  Even though my host name resolves correctly through
dns and the reverse lookup gives the right IP address, it is not enought to put
the fully qualified domain name in /etc/mail/access.  I had to include the IP
address in /etc/mail/access.

For anyone that's reading this, just include the IP address of your clients(s)
in the file /etc/mail/access, run "makemap hash /etc/mail/access <
/etc/mail/access", then "service sendmail restart".
Comment 2 Carl T. Miller 2002-10-27 19:48:30 EST
Just an after-thought...if I'm logged into a host and sending mail, why is it
making the connection through the network interface instead of the loopback
device?  In other words, why use computer.carltm.com instead of localhost? 
Early versions of Red Hat didn't have this issue.
Comment 3 Carl T. Miller 2002-10-28 21:21:27 EST
I needed to reinstall the OS, and noticed that this problem did not happen.  The
only difference is that the first time I gave the computer a hostname during the
installation.  This time I didn't give it a hostname, so it used
localhost.localdomain.  When the computer came up, it got the correct hostname
and  IP address from the dhcp server, and when I run hostname it says
computer.carltm.com, but now it sees email as coming from localhost.localdomain.  

It seems odd to me that assigning a hostname during installation would make any
Comment 4 Bill Nottingham 2006-08-04 16:09:05 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.