Bug 76455 - oprofile module wont load
oprofile module wont load
Product: Red Hat Linux
Classification: Retired
Component: oprofile (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: William Cohen
Depends On:
  Show dependency treegraph
Reported: 2002-10-21 20:46 EDT by Ian Ollmann
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-03-26 15:14:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
grub.conf file with "nortc" option (550 bytes, text/plain)
2002-10-22 10:28 EDT, William Cohen
no flags Details

  None (edit)
Description Ian Ollmann 2002-10-21 20:46:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
# op_start
/usr/bin/op_start: line 110: modprobe: command not found
Couldn't load oprofile.o module

go edit /usr/bin/op_start and change line 110 to have the full path to modprobe,
then try again:

# op_start
modprobe: Can't locate module oprofile
Couldn't load oprofile.o module

# rpm -qa | grep kernel

# rpm -qa | grep oprofile

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Install RedHad


Actual Results:  errors see above

Additional info:

Comment 1 William Cohen 2002-10-22 10:26:40 EDT
The messages "Couldn't load oprofile.o module" is misleading. On Red Hat Linux
8.0 oprofile is not built as a module; it is compiled into the kernel. The
problem is caused by the conflict between the RTC driver and the OProfile
driver. Both drivers are compiled into the default kernel. OProfile provided
with Red Hat Linux 8.0 does not support the Pentium 4 performance monitoring
hardware, so OProfile attempts to use the RTC mechanism.

To use the OProfile supplied with Red Hat Linux 8.0 on Pentium 4 you will need
to append the "nortc" option in /boot/grub/grub.conf for the appropriate kernel
command line.
Comment 2 William Cohen 2002-10-22 10:28:48 EDT
Created attachment 81565 [details]
grub.conf file with "nortc" option
Comment 3 Ian Ollmann 2002-10-22 17:05:16 EDT
Gave that a try. Still doesn't work. I'm actually using LILO, if it makes any

        append="root=LABEL=/ nortc"

# op_start a.out
modprobe: Can't locate module oprofile
Couldn't load oprofile.o module

I see oprofile does not appear to be listed in /proc/devices

Perhaps there is more to this puzzle?
Comment 4 Christoph Breitkopf 2002-12-06 07:02:59 EST
FYI: The same error happens on a Pentium III system:

[root@eddie root]# op_start
modprobe: Can't locate module oprofile
Couldn't load oprofile.o module
Comment 5 Christoph Breitkopf 2002-12-06 09:57:17 EST
Sigh. oprofile support is _not_ compiled into the 2.4.18-18.0 kernel.
I compiled a kernel with oprofile support enabled and everything
works. After reading "Red Hat Linux 8.0 Release Notes" I got the
impression that oprofile was enabled in the standard RedHat kernel -
this is not the case, apparently.
Comment 6 William Cohen 2002-12-06 10:55:23 EST
OProfile was compiled into all the i686 kernels for the initial release of RH
8.0. The updated uniprocessors kernels do not have it compiled it. Some laptops
do not deal well with the interrupts produced by oprofile due to the power
management and the laptop chipset. Thus, the uniprocessors kernels are not
currently built with oprofile enabled. The SMP kernels have it enabled. Install
the SMP kernel to get the OProfile support in the kernel. The SMP kernel should
work on uniprocessor machines.
Comment 7 Christopher Smith 2003-03-10 15:12:12 EST
I am experiencing the same problem on my SMP system:

[root@shamir workspace]# uname -r
[root@shamir workspace]# op_start
/usr/local/bin/op_start: line 80: modprobe: command not found
Couldn't load oprofile.o module

I changed my grub.conf to read:

"kernel /vmlinuz-2.4.18-26.8.0smp ro root=LABEL=/ nortc"

and it made no difference.
Comment 8 Christopher Smith 2003-03-13 20:24:26 EST
Scratch my last report. I had a vestigal copy of the new Oprofile installed on
my system. Once I removed it, everything was fine.

Note You need to log in before you can comment on or make changes to this bug.