Bug 764619 - (GLUSTER-2887) Providing native systemd service file for glusterd and glusterfsd
Providing native systemd service file for glusterd and glusterfsd
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
pre-2.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Vijay Bellur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-06 13:25 EDT by Jóhann B. Guðmundsson
Modified: 2014-11-09 06:30 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-09 06:30:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
native systemd service files for glusterd (328 bytes, text/plain)
2011-05-06 10:25 EDT, Jóhann B. Guðmundsson
no flags Details
native systemd service files for glusterfsd (326 bytes, text/plain)
2011-05-06 10:26 EDT, Jóhann B. Guðmundsson
no flags Details
native systemd service files for glusterfsd (261 bytes, text/plain)
2011-10-27 08:41 EDT, Jóhann B. Guðmundsson
no flags Details
native systemd service files for glusterd (264 bytes, text/plain)
2011-10-27 08:44 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-05-06 10:26:35 EDT
Created attachment 482
Comment 1 Jóhann B. Guðmundsson 2011-05-06 13:25:49 EDT
Providing native systemd service file which replace the old sysv on linux platform see http://www.freedesktop.org/wiki/Software/systemd for details

To test this copy the attached files to /lib/systemd/system on Fedora 15 or newer 

run "systemctl daemon-reload" to let systemd pick up the native systemd service files.

To start an service run 

systemctl start glusterd.service ( this will also start glusterfsd.service )

To restart an service run 

systemctl restart glusterd.service 

systemctl restart glusterfsd.service 

To stop an service run 

systemctl stop glusterd.service 

systemctl stop glusterfsd.service 

To enable or disable a service at boot up run

systemctl enable/disable glusterd.service

systemctl enable/disable glusterfsd.service

I think this is enough for the first round on this report I'm expecting bunch of questions from you guys now there are no environmental option pick up from the environment file when starting the daemon ( /etc/sysconfig/glusterd ) in the service files because well the one of them is a at least obsolete and it's an question if you just want that handled by downstream.
Comment 2 Amar Tumballi 2011-09-30 02:32:23 EDT
Will work on this after 3.3.0 release.
Comment 3 Jóhann B. Guðmundsson 2011-10-27 08:41:07 EDT
Created attachment 712


Updating to current status of systemd...

Removed syslog.target no longer necessary.
Changed PID Path from /var/run to /run
Removed EnvironmentFile /etc/sysconfig/glusterfsd since users/administrators should copy the unit file from /lib/systemd/system to /etc/systemd/system and edit/add the relevant options from that sysconfig file there.
Comment 4 Jóhann B. Guðmundsson 2011-10-27 08:44:24 EDT
Created attachment 713


Updating to current status of systemd...

Removed syslog.target no longer necessary.
Changed PID Path from /var/run to /run
Removed EnvironmentFile /etc/sysconfig/glusterfsd since users/administrators
should copy the unit file from /lib/systemd/system to /etc/systemd/system and
edit/add the relevant options from that sysconfig file there.

Removed an extra '=' line in the Wants line
Comment 5 Niels de Vos 2014-11-09 06:30:54 EST
This should be fixed in current releases. The extras/systemd/ directory in the sources contain the systemd-unit files. These get included in the RPMs when buidling on a distribution that uses systemd.

In case the systemd units do not work as they should, please file a new bug report dedicated to that particular issue.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.