Bug 76464 - rpm does not return from Upgrade command
rpm does not return from Upgrade command
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Depends On:
  Show dependency treegraph
Reported: 2002-10-21 22:39 EDT by Florin Andrei
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-21 22:57:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2002-10-21 22:39:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
get transcode- tarball from here:
Rebuild it:
rpmbuild -ta --rebuild --target=athlon transcode....
Then install the binary:
rpm -Uvh transcode....
The last command does not return the prompt in xterm. I tried to kill the rpm
process, but it does not respond; i didn't tried a -9 yet.

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Steps to Reproduce:
1.rebuild transcode-
2.install (-U) the binary

Actual Results:  rpm command is frozen

Expected Results:  rpm should upgrade the package

Additional info:
Comment 1 Florin Andrei 2002-10-21 22:57:02 EDT
Ok, i "kill -9"'ed rpm, run a "rpm -qa | grep transcode", and sure thing, there
were two versions installed.
I removed dvd::rip first (it depends on transcode), then did a "rpm -ev
--allmatches transcode".
Then i attempted again to install my newly built package. It worked. I
reinstalled dvd::rip afterwards... Nothing suspicious so far.
But i wonder if my RPM database is still healthy. :-(
Comment 2 Jeff Johnson 2002-10-23 10:58:57 EDT
Doing --rebuilddb with rpm-4.1 guarantees (by checking signatures
and digests of headers, and rebuilding all other indices)
a "healthy" database, for some pretty meaningful definition
of "healthy".

Note You need to log in before you can comment on or make changes to this bug.