Bug 76466 - mkinitrd too strict when parsing /etc/raidtab
Summary: mkinitrd too strict when parsing /etc/raidtab
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-22 04:03 UTC by Ian Pilcher
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2002-10-22 04:03:12 UTC


Attachments (Terms of Use)

Description Ian Pilcher 2002-10-22 04:03:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021020

Description of problem:
mkinitrd parses /etc/raidtab to determine whether it need to include RAID
support.  The current version only works, however, if there is a tab before the
"raid-level" keyword.  If there are only four spaces, for example, mkinitrd will
not include RAID support.  This can easily lead to an unbootable system --
particularly because Red Hat 7.3 was more forgiving in this regard.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install Red Hat Linux 8.0 onto a RAID-1 root partition.
2.  Modify /etc/raidtab, replacing tabs with spaces.
3.  Run mkinitrd (or upgrade kernel RPMS).  The system will not be able to boot
with the new initrd image.
	

Actual Results:  RAID support not included in resulting initrd image.

Expected Results:  mkinitrd should have detected that root partition was on a
RAID-1 device and included support.

Additional info:

Putting this as high severity, since it can lead to unbootable systems
(probably also because it took me about 8 hours to figure out what was going on).

Comment 1 Erik Troan 2002-11-05 21:50:37 UTC
fixed in 3.4.30 -- not going to errata this unless there are more reports.

Comment 2 Zing 2002-11-15 18:43:49 UTC
Just reporting that I just hit this buglet.  I see this could trip up people,
but i don't really mind if an errata is done or not.

Comment 3 Stephen Tweedie 2002-11-29 14:35:59 UTC
It just hit me too, if you're still counting reports.


Note You need to log in before you can comment on or make changes to this bug.