Bug 76468 - Main screen of Apache Configuration utility "add addresses" puts more than one address as parameter for listen causing Apache to not start
Main screen of Apache Configuration utility "add addresses" puts more than on...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-httpd (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-22 01:04 EDT by Harold Hallikainen
Modified: 2015-03-04 20:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-06 11:11:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harold Hallikainen 2002-10-22 01:04:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win95; U)

Description of problem:
Using the main tab of Apache Configuration graphic utility to add to available addresses results in added addresses all on one line after one "listen". Apache wants a 
separate listen for each address. Here's a bit of the resulting httpd.conf:

Listen *.80 *:443

This should be something like

Listen *:80
Listen *.443

or 

Listen 80
Listen 443

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. From main tab of Apache Config utility, hit add
2. Either put a * in address or choose Listen to all addresses
3. Put 443 in port.
4. Restart httpd and see error message.
5. Look at httpd.conf and see two addresses or ports after Listen
	

Actual Results:  Apache would not start due to error in httpd.conf generated by graphical configuration utility

Expected Results:  It should have not made the error (should have put in a separate listen line for each address or port)

Additional info:
Comment 1 Phil Knirsch 2003-02-06 11:11:51 EST
OK, fixed in CVS, rawhide package will be available soon.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.