Bug 7647 - Cannot mount floppy or cdrom
Cannot mount floppy or cdrom
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-06 23:36 EST by Bobby Moore
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-08 10:11:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bobby Moore 1999-12-06 23:36:57 EST
The cdrom won't mount.

i/p: mount /dev/cdrom /mnt/cdrom
o/p: mount: you must specify the filesystem type

i/p: mount /dev/cdrom /mnt/cdrom -t iso9660
o/p: mount: /dev/cdrom has wrong major or minor number

Mounting worked using Red Hat 5.2 and 6.0. It worked on installs of Red Hat
6.1. The machine it's not working on was a machine that was upgraded from
6.0.

The same is true for the floppy.
Comment 1 Bernhard Rosenkraenzer 1999-12-08 10:11:59 EST
Looks like your /dev tree got messed up.
Make sure /dev/cdrom is a link to the actual drive (usually /dev/hdc (IDE) or
/dev/sr0 (SCSI)).
Comment 2 Riley H Williams 1999-12-12 11:40:59 EST
Actually, this looks like a buglet I've had a few times on my system, where the
reported error message is always the one displayed. If so, then you have the
filetype in /etc/fstab set to "auto" and iso9660 compiled as a module and NOT
loaded when you issue the command.

I've had the same problem with /dev/fd0 set to "auto" and vfat compiled modular
- I don't have msdos compiled in at all. For some reason, even if one specifies
the filesystem type, the kernel makes no attempt to load the module in this
case.

Note You need to log in before you can comment on or make changes to this bug.