This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 764732 - (GLUSTER-3000) Add -devel package for headers
Add -devel package for headers
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Amar Tumballi
Sachidananda Urs
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2011-06-07 17:20 EDT by Jeff Darcy
Modified: 2013-12-18 19:06 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:43:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Darcy 2011-06-07 17:20:55 EDT
OK, I admit it, I did this partly to get bug 764732.  Seriously, though, since extensibility is one of the most significant benefits of GlusterFS relative to most alternatives, I think it's imperative to facilitate actual extension without needing to have a full GlusterFS source tree available (which violates many projects' packaging guidelines).  For CloudFS I've managed to build translators "out of tree" using simple makefiles and only headers installed as part of the Fedora glusterfs-devel package.  Ideally this same work would also apply to Gluster's own packaging, to Debian, etc.  Also, the particular files that are part of the "external API" represented by the -devel package - especially those necessary to build any translator - should be carefully chosen and clearly identified (e.g. by placing them in a single directory).  Right now that's not the case, with some essential header files buried e.g. in contrib/uuid and every include directory mingling essential with non-essential files.
Comment 1 Amar Tumballi 2011-10-24 23:56:13 EDT
Jeff,

Let me know what is your thought on this now.

Regards,
Amar
Comment 2 Amar Tumballi 2012-03-06 01:23:05 EST
After merging Joe's Patch to make it FHS compatible, this should be fixed.
Comment 3 Sachidananda Urs 2012-05-31 03:35:43 EDT
Amar can you give me the commit id/patch number/url to verify. I think it is e8b6dad4dea4535a179a03824aa44628f9adaa17, need your clarification.
Comment 4 Sachidananda Urs 2012-05-31 03:37:31 EDT
Not part of release, will verify again.
Comment 5 Sachidananda Urs 2012-05-31 03:44:14 EDT
My bad, I see the spec changes in 3.3.0 tar ball, and the new rpms are built on the new spec.

Note You need to log in before you can comment on or make changes to this bug.