Bug 764795 - (GLUSTER-3063) [RFE] pid-file placements are awkward
[RFE] pid-file placements are awkward
Status: CLOSED DUPLICATE of bug 1258561
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
All Linux
low Severity low
: ---
: ---
Assigned To: Vijay Bellur
: FutureFeature, Reopened, RFE, Triaged
Depends On: 1258561
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-20 20:29 EDT by Joe Julian
Modified: 2017-08-11 03:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-11 11:35:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Julian 2011-06-20 20:29:05 EDT
The pid files are kind-of immobile. The right place for them under RedHat based distributions would be under /var/run but even if I specify '-p /var/run/glusterfs/glusterd.pid' when starting glusterd, that has no effect on the locations of the nfs, glusterfsd, glusterfs or gsync pid files.

I feel the better structure is to have them based on a pid-directory structure rather than volume/service based. For instance:
{pid-root}/glusterd.pid
{pid-root}/nfs.pid (or {pid-root}/nfs/nfs.pid)
{pid-root}/gsync/volume1-server2-data-volume1.pid
{pid-root}/bricks/server1-data-brick1.pid
{pid-root}/bricks/server1-data-brick2.pid
{pid-root}/fuse/volume1-rb_dst_brick.pid

The command-line option I would envision to go along with that would then be '--pid-root'.
Comment 1 Amar Tumballi 2012-02-27 05:43:22 EST
priority will be re-addressed after 3.3.0 GA
Comment 2 Shawn Heisey 2012-09-28 16:33:20 EDT
I have run into a related problem.  The gluster-swift packages by kkeithley create a 'swift.pid' file in a subdirectory of /var/lib/glusterd/vols/$volname.  When you issue "gluster volume delete $volname" it is unable to delete the volume directory because of this file.  I have filed bug 861497 for the general problem with the volume directory not getting fully removed on volume deletion.

General comment: It seems like a very bad idea for one package (gluster-swift) to put its pid file in a directory that is created and managed at runtime by another package (gluster).
Comment 3 Kaleb KEITHLEY 2015-10-22 11:46:38 EDT
because of the large number of bugs filed against mainline version\ is ambiguous and about to be removed as a choice.

If you believe this is still a bug, please change the status back to NEW and choose the appropriate, applicable version for it.
Comment 5 Atin Mukherjee 2017-04-11 11:35:26 EDT

*** This bug has been marked as a duplicate of bug 1258561 ***

Note You need to log in before you can comment on or make changes to this bug.