Bug 7648 - Default 6.1 install: no boot floppy, LILO hangs with "LI"
Default 6.1 install: no boot floppy, LILO hangs with "LI"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
: 7790 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-07 00:16 EST by zenon
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-04 17:26:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zenon 1999-12-07 00:16:14 EST
First: I have upgraded my purchased product from Linux 6.0 to Red Hat
Professional 6.1 and decided to make a new complete installation.

So, during the complete SERVER installation from the CD1 I was not
asked to create bootable floppy. After completed installation the
system attempted to boot from the hard disk but hanged with LI.
Strange, because the /boot is created at the beggining of the disk,
(and is small: only 17 blocks). Just to help myself I have tried to
boot from the bootable floppy which I got during 6.0 installation:
My new system booted, but did not activate some loadable modules,
because the kernel versions were different and were no suitable
module directory.

In other words, the default installation of the Server version 6.1
may result in non-bootable system.

My hardware: standard IBM Netfinity 7000 server.
Comment 1 zenon 1999-12-07 11:18:59 EST
A workaround (works if you have 6.0 system, or disk with it, at hand):

The following trick worked OK:
1. I have two disks on my system. As reported, the basic "Server" 6.1
   installation on one of the disks failed, because lilo hangs with LI and
   no bootable floppies were created.
2. I had another disk in the system with 6.0 system installed - the 6.0
   procedure included creation of bootable floppy, which made the difference.
3. Used the bootable floppy from the 6.0 system to boot from the newly installed
   6.1 system. It reported missing /lib/modules/2.2.5-* kernel modules, and as
   a result I could not use the "mkbootdisk" utility.
4. From another disk (you can do it from another system using floppies) I have
   copied /lib/modules/2.2.5-* to my newly installed system, which contained
   own /lib/modules/2.2.12-* modules.
5. Then the system was rebooted (using the same 6.0 bootable floppy). This time
   no missing modules were reported (obviously).
6. Noted the name of the new 6.1 kernel (ls /lib/modules had shown the full
   name of the 2.2.12-* kernel, say 2.2.12-22).
   Executed
      # mkbootdisk 2.2.12-22
The new created bootable floppy booted the 6.1 version of kernel, as intended.

(One could remove now the /lib/modules/2.2.5-*)
Comment 2 zenon 1999-12-12 23:50:59 EST
As explained above, I was able to create bootable LILO floppy, which
boots the 2.2.12-* kernel. However, running lilo with the standard
/etc/lilo.conf (which installed lilo on /dev/sda disk), and attemping
to boot without bootable floppy, still resulted with handing at "LI"
prompt.

Now, I experimented with modifications to the /etc/lilo.conf and it
happened, that for my HD (which is 9.1 GB SCSI disk) the "linear" option
solved the problem. My current lilo.conf file looks like follows:
  boot=/dev/sda
  map=/boot/map
  install=/boot/boot.b
  prompt
  linear
  timeout=50
  default=linux

  image=/boot/vmlinuz-2.2.12-20smp
        label=linux
        initrd=/boot/initrd-2.2.12-20smp.img
        read-only
        root=/dev/sda8

  image=/boot/vmlinuz-2.2.12-20
        label=linux-up
        initrd=/boot/initrd-2.2.12-20.img
        read-only
        root=/dev/sda8
Comment 3 Cristian Gafton 2000-01-04 17:26:59 EST
Assigned to dledford
Comment 4 Jeremy Katz 2002-06-04 01:00:03 EDT
In older releases, you were required to select the linear box during the install
process to use linear mode, which is required for some scsi controllers and
drives.  In newer releases, we always use linear mode when installing lilo.
Comment 5 Jeremy Katz 2002-06-04 01:00:23 EDT
*** Bug 7790 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.